summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornicovell32021-06-16 23:59:08 +0200
committernicovell32021-06-16 23:59:08 +0200
commit99d2c9865f52453678ccd908e2e870ed1bfe34d3 (patch)
tree6fb3dd94463a3d01f69e3830dffda3057ed3d53b
parent35ffbb0b925664f27dac4d1e8198beecdcece6d8 (diff)
downloadaur-99d2c9865f52453678ccd908e2e870ed1bfe34d3.tar.gz
Adding malacology suggested method to update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD4
-rwxr-xr-xupdateScript.sh8
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ef9d9848634..65ae82c66fa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = gnome-shell-extension-tray-icons
pkgdesc = Simple version of TopIcons Plus
- pkgver = 4
+ pkgver = 6
pkgrel = 1
url = https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons
arch = any
license = GPL3
depends = gnome-shell
- source = https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons/archive/v4.tar.gz
- sha256sums = bdc7227fb5518cee52f116ee20412f0375156016218b832ae83356842f1de6a6
+ source = https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons/archive/v6.tar.gz
+ sha256sums = 39062a45acc15a13bebde3bed48a99d6ead34140826c3a07eaea64a3398159c1
pkgname = gnome-shell-extension-tray-icons
-
diff --git a/PKGBUILD b/PKGBUILD
index 7ee4691db782..ca92c66d0f65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@ pkgver=6
pkgrel=1
pkgdesc="Simple version of TopIcons Plus"
arch=('any')
-url="https://github.com/nicovell3/gnome-shell-extension-tray-icons"
+url="https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons"
license=('GPL3')
depends=('gnome-shell')
source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('f2fb870b3c4487449cf5befffeb94d6ea23a592986ec9aaee37060a568a570c5')
+sha256sums=('39062a45acc15a13bebde3bed48a99d6ead34140826c3a07eaea64a3398159c1')
package() {
cd "$pkgname-$pkgver"
diff --git a/updateScript.sh b/updateScript.sh
new file mode 100755
index 000000000000..1dc36914cb59
--- /dev/null
+++ b/updateScript.sh
@@ -0,0 +1,8 @@
+#!/bin/bash
+updpkgsums
+source PKGBUILD
+rm v${pkgver}.tar.gz
+makepkg --printsrcinfo > .SRCINFO
+git add .
+git commit -m "$1"
+git push