summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornicovell32021-11-12 12:04:27 +0100
committernicovell32021-11-12 12:04:27 +0100
commitd4deb965bf326789625101bdd56598e0c2539635 (patch)
tree8065d3a2bd33a94fdb59d4f296062544f3d8a123
parentc14719166a8b62970b1df9583801487c4a909135 (diff)
downloadaur-d4deb965bf326789625101bdd56598e0c2539635.tar.gz
Add update instructions
-rw-r--r--updateInstructions14
1 files changed, 14 insertions, 0 deletions
diff --git a/updateInstructions b/updateInstructions
new file mode 100644
index 000000000000..881290947f86
--- /dev/null
+++ b/updateInstructions
@@ -0,0 +1,14 @@
+# Updating extension for Gnome $version with tag $tag
+# Update metadata.json on extension project
+vi metadata.json
+# Deploy and logout to test
+cp metadata.json /usr/share/gnome-shell/extensions/tray-icons@nicovell3/metadata.json
+# Upload changes
+git commit -m "Update to version ${version}"
+git tag v${tag}
+git push origin --tags
+
+# Update pkgver in aur project
+vi PKGBUILD
+# Run update script
+bash updateScript.sh "Update for Gnome $version"