summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThanosApostolou2019-01-12 01:39:04 +0200
committerThanosApostolou2019-01-12 01:39:04 +0200
commite47b09b7e497ca0ed5f5461f334075050219044c (patch)
tree0152ea0da91a2a3358e18dcb6de5bf92d361eec0
downloadaur-e47b09b7e497ca0ed5f5461f334075050219044c.tar.gz
initial inclusion
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6b751cb54f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-tray-icons
+ pkgdesc = Simple version of TopIcons Plus
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ source = https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons/archive/v1.tar.gz
+ sha256sums = 0ab28cc110006e29c27a295d0f32d07c5e7c0053f3fa9ad4946995d2f040544c
+
+pkgname = gnome-shell-extension-tray-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d6e2b3b0693
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Thanos Apostolou <thanosapostolou@outlook.com>
+
+pkgname=gnome-shell-extension-tray-icons
+pkgver=1
+pkgrel=1
+pkgdesc="Simple version of TopIcons Plus"
+arch=('any')
+url="https://github.com/zhangkaizhao/gnome-shell-extension-tray-icons"
+license=('GPL3')
+depends=('gnome-shell')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('0ab28cc110006e29c27a295d0f32d07c5e7c0053f3fa9ad4946995d2f040544c')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/tray-icons@zhangkaizhao.com"
+ install -Dm644 extension.js "${pkgdir}/usr/share/gnome-shell/extensions/tray-icons@zhangkaizhao.com/extension.js"
+ install -Dm644 metadata.json "${pkgdir}/usr/share/gnome-shell/extensions/tray-icons@zhangkaizhao.com/metadata.json"
+}