summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorstarsareintherose2021-10-21 01:16:12 +0100
committerstarsareintherose2021-10-21 01:16:12 +0100
commit23770b348a5b5598a17bba4b1b95e802908e02c0 (patch)
tree24b60dcda446837e4c9a0c8dcddef156096f93e4
downloadaur-23770b348a5b5598a17bba4b1b95e802908e02c0.tar.gz
17
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33790120192c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gnome-shell-extension-tray-icons-reloaded
+ pkgdesc = GNOME Shell extension which bring back Tray Icons to top panel, with additional features.
+ pkgver = 17
+ pkgrel = 1
+ url = https://github.com/MartinPL/Tray-Icons-Reloaded
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ source = https://github.com/MartinPL/Tray-Icons-Reloaded/releases/download/17/trayIconsReloaded@selfmade.pl.zip
+ sha256sums = aea76e40e5abe29b91efff76d184b0747e1f29991b0246cdc18e02030a06d01b
+
+pkgname = gnome-shell-extension-tray-icons-reloaded
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..ed5a82190ba2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Guoyi Zhang <GuoyiZhang at malacology dot net>
+# Contributor: Guoyi Zhang <GuoyiZhang at malacology dot net>
+
+pkgname=gnome-shell-extension-tray-icons-reloaded
+pkgver=17
+_name=trayIconsReloaded@selfmade.pl
+pkgrel=1
+pkgdesc="GNOME Shell extension which bring back Tray Icons to top panel, with additional features."
+arch=('any')
+url="https://github.com/MartinPL/Tray-Icons-Reloaded"
+license=('GPL3')
+depends=('gnome-shell')
+source=("https://github.com/MartinPL/Tray-Icons-Reloaded/releases/download/$pkgver/$_name.zip")
+sha256sums=('aea76e40e5abe29b91efff76d184b0747e1f29991b0246cdc18e02030a06d01b')
+
+package() {
+
+ cd $srcdir
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ local destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ install -dm755 "$destdir"
+
+ cp -r * "$destdir"
+}