summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramoka2019-02-22 23:00:00 -0500
committeramoka2019-02-22 23:00:00 -0500
commitf3704481c2623128a28d632daf84184816487a88 (patch)
tree8dd8c03725d3b5f4943cf3e42e5fea6992e4313d
parent1c18c3fb35fc56f21a96ecfcb739b524b42dec37 (diff)
downloadaur-f3704481c2623128a28d632daf84184816487a88.tar.gz
update to a new version and modify PKGBUILD
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56ba31506907..316fcf63c458 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = gnome-shell-extension-ubuntu-dock
- pkgdesc = The gnome extension that provides the new ubuntu dock
- pkgver = 0.9.1
+ pkgdesc = A dock for the Gnome Shell
+ pkgver = 64ubuntu3
pkgrel = 1
url = https://github.com/micheleg/dash-to-dock/tree/ubuntu-dock
arch = any
license = GPL
- makedepends = git
+ makedepends = intltool
+ makedepends = gettext
depends = gnome-shell
- source = http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-shell-extension-ubuntu-dock/gnome-shell-extension-ubuntu-dock_0.9.1.tar.xz
- sha256sums = bc5aa040fe325cdcbb193fb5269701a6a6f0746d31910d56f23ce576aee31194
+ source = http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-shell-extension-ubuntu-dock/gnome-shell-extension-ubuntu-dock_64ubuntu3.tar.xz
+ sha256sums = d8352b85dd44eabd99d91bdd81cce24e2efcd1862614aa5262c67417e985a6a0
pkgname = gnome-shell-extension-ubuntu-dock
diff --git a/PKGBUILD b/PKGBUILD
index eeaaba2ed0a5..55731d7021b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Jacob Humphrey (kaknife) <jacob.ryan.humphrey@gmail.com>
+# Maintainer: Amanoel Dawod <amanoel at outlook dot com>
+# Contributor: Jacob Humphrey (kaknife) <jacob.ryan.humphrey@gmail.com>
-
-pkgname=gnome-shell-extension-ubuntu-dock
-pkgver=0.9.1
+pkgname=gnome-shell-extension-ubuntu-dock
+pkgver=64ubuntu3
pkgrel=1
-pkgdesc="The gnome extension that provides the new ubuntu dock"
+pkgdesc="A dock for the Gnome Shell"
+arch=('any')
url="https://github.com/micheleg/dash-to-dock/tree/ubuntu-dock"
-arch=(any)
-license=(GPL)
-depends=(gnome-shell)
-makedepends=(git)
-sha256sums=("bc5aa040fe325cdcbb193fb5269701a6a6f0746d31910d56f23ce576aee31194")
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('intltool' 'gettext')
source=("http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-shell-extension-ubuntu-dock/${pkgname}_${pkgver}.tar.xz")
+sha256sums=('d8352b85dd44eabd99d91bdd81cce24e2efcd1862614aa5262c67417e985a6a0')
-prepare() {
- bsdtar xf ${pkgname}_${pkgver}.tar.xz
+build() {
+ cd ${pkgname}-${pkgver}
+ make
}
package() {
- cd dash-to-dock
- make DESTDIR="$pkgdir" install
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" VERSION="${pkgver}" install
}