summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonian Guveli2017-08-23 22:21:17 +0300
committerJonian Guveli2017-08-23 22:21:17 +0300
commit0724a3e83f266557bc7d3fed82f86079a17e8c76 (patch)
tree55da2b86d0277621590e5d81bf0798c7595ff28c
downloadaur-0724a3e83f266557bc7d3fed82f86079a17e8c76.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e657019973ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Aug 23 19:20:54 UTC 2017
+pkgbase = gnome-shell-extension-unite-git
+ pkgdesc = Unite makes GNOME Shell look like Ubuntu Unity Shell
+ pkgver = 46.b3203ca
+ pkgrel = 1
+ url = https://github.com/jonian/unite-shell
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ depends = xorg-xprop
+ provides = gnome-shell-extension-unite
+ source = gnome-shell-extension-unite-git::git+https://github.com/jonian/unite-shell
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-unite-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e787d4c61b80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=gnome-shell-extension-unite-git
+pkgver=46.b3203ca
+pkgrel=1
+pkgdesc="Unite makes GNOME Shell look like Ubuntu Unity Shell"
+arch=("any")
+url="https://github.com/jonian/unite-shell"
+license=("GPL")
+depends=("gnome-shell" "xorg-xprop")
+makedepends=("git")
+provides=("gnome-shell-extension-unite")
+source=("$pkgname::git+https://github.com/jonian/unite-shell")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+
+ cd "$srcdir/$pkgname/dist"
+ cp -af "unite@hardpixel.eu" "$pkgdir/usr/share/gnome-shell/extensions/"
+}