summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wiesner2023-10-15 19:23:52 +0200
committerSebastian Wiesner2023-10-15 19:24:14 +0200
commitaf851d0863e84e4318dc6123b33175f2028b2b9c (patch)
treed4196509c2a068e5331b6917c5c2d581e5e758fa
downloadaur-af851d0863e84e4318dc6123b33175f2028b2b9c.tar.gz
Initial upload: gnome-shell-extension-utc-clock 2-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42510a35a4e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-utc-clock
+ pkgdesc = Extension for GNOME shell to add a UTC clock to the top bar
+ pkgver = 2
+ pkgrel = 1
+ url = https://github.com/swsnr/gnome-shell-extension-utc-clock
+ arch = any
+ license = MPL2
+ makedepends = npm
+ depends = gnome-shell
+ source = gnome-shell-extension-utc-clock-2.tar.gz::https://github.com/swsnr/gnome-shell-extension-utc-clock/archive/ego-2.tar.gz
+ sha256sums = 461fc82c64090abd6c4044b286114a23e35d52b0d119e4128d8c404e8fc66d3c
+
+pkgname = gnome-shell-extension-utc-clock
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..40ff3d8eb413
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.tar.gz
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..addcddc004a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
+
+pkgname=gnome-shell-extension-utc-clock
+pkgver=2
+pkgrel=1
+pkgdesc='Extension for GNOME shell to add a UTC clock to the top bar'
+arch=('any')
+url="https://github.com/swsnr/gnome-shell-extension-utc-clock"
+license=('MPL2')
+makedepends=('npm')
+depends=('gnome-shell')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/ego-${pkgver}.tar.gz")
+sha256sums=('461fc82c64090abd6c4044b286114a23e35d52b0d119e4128d8c404e8fc66d3c')
+
+build() {
+ cd "${pkgname}-ego-${pkgver}" || exit 1
+ npm ci
+ make compile
+}
+
+package() {
+ cd "${pkgname}-ego-${pkgver}" || exit 1
+ make PREFIX=/usr DESTDIR="${pkgdir}" install-system
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}