summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2022-03-19 19:25:07 -0700
committerLlewelyn Trahaearn2022-03-19 19:25:07 -0700
commite43c9d643a6dab8a4ba84f1816faf6e002b79966 (patch)
tree6e6a5c0904a7064685b4ceed2fc06fb241675bb4
downloadaur-e43c9d643a6dab8a4ba84f1816faf6e002b79966.tar.gz
Initial commit of release PKGBUILD based on the VCS PKGBUILD
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe9f9d8ed4b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnome-shell-extension-vitals
+ pkgdesc = Displays system vitals in a GNOME Shell top bar pop-down.
+ pkgver = 52.0.15
+ pkgrel = 1
+ url = https://github.com/corecoding/Vitals
+ arch = any
+ license = GPL
+ makedepends = gettext
+ makedepends = git
+ depends = dconf
+ depends = gnome-icon-theme
+ depends = gnome-icon-theme-symbolic
+ depends = gnome-shell
+ depends = libgtop
+ depends = lm_sensors
+ source = gnome-shell-extension-vitals::git+https://github.com/corecoding/Vitals#tag=v52.0.15
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-vitals
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c50e32a1a6a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Llewelyn Trahaearn <WoefulDerelict at GMail dot com>
+
+pkgname=gnome-shell-extension-vitals
+pkgver=52.0.15
+pkgrel=1
+pkgdesc="Displays system vitals in a GNOME Shell top bar pop-down."
+arch=('any')
+url="https://github.com/corecoding/Vitals"
+license=('GPL')
+depends=('dconf' 'gnome-icon-theme' 'gnome-icon-theme-symbolic' 'gnome-shell' 'libgtop' 'lm_sensors')
+makedepends=('gettext' 'git')
+source=("${pkgname}::git+${url}#tag=v${pkgver}")
+sha512sums=('SKIP')
+
+build() {
+ cd "${pkgname}"/locale
+ for locale in */
+ do
+ msgfmt -o "${locale}/LC_MESSAGES"/vitals.mo "${locale}/LC_MESSAGES"/vitals.po
+ done
+}
+
+package() {
+ # Locate the extension.
+ cd "$(dirname $(find -name 'metadata.json' -print -quit))"
+ _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ # Copy extension files into place.
+ find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "${_destdir}" '{}' +
+ find -maxdepth 2 \( -iname '*.svg*' \) -exec install -Dm644 -t "${_destdir}/icons" '{}' +
+ find -name '*.xml' -exec install -Dm644 -t "${pkgdir}/usr/share/glib-2.0/schemas/" '{}' +
+ cp -r --no-preserve=ownership,mode helpers "${_destdir}"
+ cd locale
+ for locale in */
+ do
+ install -Dm644 -t "${pkgdir}/usr/share/locale/${locale}/LC_MESSAGES" "${locale}/LC_MESSAGES"/*.mo
+ done
+}