summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrliang2017-09-18 20:11:05 -0300
committerrliang2017-09-18 20:11:05 -0300
commit3b07edd48842bd060cc41eb3ea2effb2e0c26215 (patch)
treef2bce32bbbbc0f027ce95c58b8c6edd04d9ce88b
downloadaur-3b07edd48842bd060cc41eb3ea2effb2e0c26215.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be4b396e9c09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-window-animations-git
+ pkgdesc = Adds task icons grouped by workspace to the panel.
+ pkgver = r16.be678c7
+ pkgrel = 1
+ url = https://github.com/rliang/gnome-shell-extension-window-animations
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = gnome-shell
+ conflicts = gnome-shell-extension-window-animations
+ source = gnome-shell-extension-window-animations-git::git+https://github.com/rliang/gnome-shell-extension-window-animations.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-window-animations-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11c4a45d75b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ricardo Liang <ricardoliang at gmail dot com>
+pkgname=gnome-shell-extension-window-animations-git
+pkgver=r16.be678c7
+pkgrel=1
+pkgdesc='Adds task icons grouped by workspace to the panel.'
+arch=('any')
+url="https://github.com/rliang/gnome-shell-extension-window-animations"
+license=('MIT')
+depends=('gnome-shell')
+makedepends=('git')
+optdepends=()
+conflicts=('gnome-shell-extension-window-animations')
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${pkgname}"
+
+ local _extname="$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)"
+
+ install -Dm644 -t "${pkgdir}/usr/share/gnome-shell/extensions/${_extname}" *.js *.json gschemas.compiled
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}