summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThanosApostolou2019-01-11 16:36:20 +0200
committerThanosApostolou2019-01-11 16:36:20 +0200
commit656eca344568de337e536b6899a68921b120bac2 (patch)
treefac1e56497104d4b2fab05a5e17601f2a1549c61
downloadaur-656eca344568de337e536b6899a68921b120bac2.tar.gz
initial inclusion
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD32
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67abef50ea82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gnome-shell-extension-windowoverlay-icons
+ pkgver = 33
+ pkgrel = 1
+ url = https://github.com/sustmi/gnome-shell-extension-windowoverlay-icons
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ source = https://github.com/sustmi/gnome-shell-extension-windowoverlay-icons/archive/v33.tar.gz
+ sha256sums = 07dd842ac5b79bf9d3b730b574d83a6ee54c65cd6ad115a65fc384913b724ad3
+
+pkgname = gnome-shell-extension-windowoverlay-icons
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc7fef36df04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thanos Apostolou <thanosapostolou@outlook.com>
+
+pkgname=gnome-shell-extension-windowoverlay-icons
+pkgver=33
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/sustmi/gnome-shell-extension-windowoverlay-icons"
+license=('GPL3')
+depends=('gnome-shell')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('07dd842ac5b79bf9d3b730b574d83a6ee54c65cd6ad115a65fc384913b724ad3')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+ make locales
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/windowoverlay-icons@sustmidown.centrum.cz"
+ install -d "${pkgdir}/usr/share/locale"
+
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/schemas/org.gnome.shell.extensions.windowoverlay-icons.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.windowoverlay-icons.gschema.xml"
+ cp -r "${srcdir}/${pkgname}-${pkgver}/locale"/* \
+ "${pkgdir}/usr/share/locale/"
+ cp -r "${srcdir}/${pkgname}-${pkgver}"/* \
+ "${pkgdir}/usr/share/gnome-shell/extensions/windowoverlay-icons@sustmidown.centrum.cz/"
+ rm -rf "${pkgdir}/usr/share/gnome-shell/extensions/windowoverlay-icons@sustmidown.centrum.cz"/{locale,schemas,po,COPYING,Makefile,README.md}
+}