summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-05-02 13:12:52 +0300
committerIgor Dyatlov2021-05-02 13:12:52 +0300
commit2b65008b547a0b5295b7cd8f13bc8c65d266beb0 (patch)
treed39d4b592837f44a94cfe0740c2d3b8444acaba0
downloadaur-2b65008b547a0b5295b7cd8f13bc8c65d266beb0.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a90039254dd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-wintile
+ pkgdesc = Windows 10 window tiling for GNOME
+ pkgver = 7
+ pkgrel = 1
+ url = https://github.com/fmstrat/wintile
+ arch = any
+ license = GPL3
+ makedepends = zip
+ depends = gnome-shell
+ source = gnome-shell-extension-wintile-7.tar.gz::https://github.com/fmstrat/wintile/archive/v7.tar.gz
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-wintile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cde7c81563ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+# Contributor: Ben Curtis <nospam@nowsci.com>
+
+pkgname=gnome-shell-extension-wintile
+pkgver=7
+pkgrel=1
+pkgdesc="Windows 10 window tiling for GNOME"
+arch=('any')
+url="https://github.com/fmstrat/wintile"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('zip')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+_srcname=wintile
+sha512sums=('SKIP')
+
+build() {
+ cd "$_srcname-$pkgver"
+ ./build.sh
+}
+
+package() {
+ cd "$_srcname-$pkgver"
+ cd "$(dirname $(find -name 'metadata.json' -print -quit))"
+ _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ bsdtar -xvf $_extname.zip -C "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+} \ No newline at end of file