summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2015-07-28 14:40:08 +0200
committerXZS2015-07-28 14:40:08 +0200
commitb2885b41c4af20f2fd882f518f38ef40a34febb7 (patch)
tree798add1a1b2e127252203993b1f4e6c122b18ea0
downloadaur-b2885b41c4af20f2fd882f518f38ef40a34febb7.tar.gz
intital import from old AUR version 3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD57
-rw-r--r--notice.install15
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46de12d8fbb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-wintitle-git
+ pkgdesc = Shows the title of window when scrolled on the appMenu button.
+ pkgver = r16.63bd614
+ pkgrel = 1
+ url = https://github.com/meghprkh/wintitle
+ install = notice.install
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-wintitle
+ conflicts = gnome-shell-extension-wintitle
+ source = gnome-shell-extension-wintitle::git+https://github.com/meghprkh/wintitle
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-wintitle-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d71b4d86e0a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: XZS <d dot f dot fischer at web dot de>
+# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
+# You may find it convenient to file issues and pull requests there.
+
+pkgname="gnome-shell-extension-wintitle-git"
+pkgdesc="Shows the title of window when scrolled on the appMenu button."
+pkgver=r16.63bd614
+pkgrel=1
+arch=(any)
+url="https://github.com/meghprkh/wintitle"
+license=(GPLv2)
+install=notice.install
+
+makedepends+=('git')
+source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
+md5sums+=('SKIP')
+provides+=($_gitname)
+conflicts+=($_gitname)
+pkgver() {
+ cd ${_gitname:-$pkgname}
+ git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
+ [ ${PIPESTATUS[0]} -ne 0 ] && \
+printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+depends[gnomeshell]=gnome-shell
+
+package_20_version() {
+ local compatibles=($(\
+ find -path ./pkg -type d -prune -o \
+ -name metadata.json -exec grep -Pzo '(?s)(?<="shell-version": \[)[^\[\]]*(?=\])' '{}' \; | \
+ tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
+ depends+=("gnome-shell>=3.${compatibles[0]}")
+ local max="${compatibles[-1]}"
+ if [ "3.$max" != $(
+ gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
+ ) ]; then
+ depends+=("gnome-shell<3.$((${max%%.*} + 1))")
+ fi
+ unset depends[gnomeshell]
+}
+package() {
+ for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
+ do
+ $function
+ done
+}
+package_01_locate() {
+ msg2 'Locating extension...'
+ cd "$(dirname $(find -name 'metadata.json' -print -quit))"
+ extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
+}
+
+package_02_install() {
+ msg2 'Installing extension code...'
+ find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) -exec install -Dm644 -t "$destdir" '{}' +
+}
diff --git a/notice.install b/notice.install
new file mode 100644
index 000000000000..bac60d6e7b45
--- /dev/null
+++ b/notice.install
@@ -0,0 +1,15 @@
+post_install() {
+ instruct
+ echo "and enable the extension with gnome-tweak-tool."
+}
+
+post_upgrade() {
+ instruct
+ echo "for the changes to have an effect."
+}
+
+instruct() {
+ echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
+}
+
+# vim: ts=2 sw=2 et: