summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-04-22 11:50:04 +0200
committerXZS2016-04-22 11:50:04 +0200
commitea28436f0b96bd343504054b9623aaafe40efbaa (patch)
tree072db1ee4a548a2ad53a362526b43d79b9da4f50
parent8a7bca0e6942c220563dee29f12bab9732f7ad4d (diff)
downloadaur-ea28436f0b96bd343504054b9623aaafe40efbaa.tar.gz
fix version comparison
Comparing the minor version to a string of minor and major will never succeed. Originally, a restriction on the current shell version was omitted for historical reasons - most packages did so when dependencies were defined manually. This now turns into a concious decision to - permit the usage of the extension in instable gnome-shell versions - the ones with odd minor version numbers - where incompatibilities are introduced gradually. - ease the transition from one stable gnome-shell version - the ones with even minor version numbers - to the next. In an ideal world, all extensions should have been updates before the update hits the repositories. But as Arch is quite more on the edge than developers of some of the extensions, this is not the case more often than not.
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fa8aab6c6158..8eed14a6b51d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,7 +49,7 @@ package_20_version() {
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"
- if [ "3.$max" != $(
+ if [ "$max" != $(
gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
) ]; then
depends+=("gnome-shell<3.$((${max%%.*} + 1))")