summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph DiGiovanni2024-01-17 19:10:42 -0500
committerJoseph DiGiovanni2024-01-17 19:10:42 -0500
commitb73a59cb42f7838a9b18ab46df5e7f0db931f801 (patch)
tree59a357a1c2dd6b7f4436b85e995fa023392f13ea
downloadaur-b73a59cb42f7838a9b18ab46df5e7f0db931f801.tar.gz
v15
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD34
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5aba67d7784b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gnome-shell-extension-wireless-hid
+ pkgdesc = Shows the battery of the wireless keyboards, mice, and game controllers
+ pkgver = 15
+ pkgrel = 1
+ url = https://github.com/vchlum/wireless-hid
+ arch = any
+ license = GPL3
+ depends = gnome-shell>=3.38
+ source = https://github.com/vchlum/wireless-hid/archive/refs/tags/15.tar.gz
+ sha256sums = e746778e1c8196fffef15d6878929fc07cf973d673b6adc65cc2d2a8b79f1c96
+
+pkgname = gnome-shell-extension-wireless-hid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3de21702b32b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..595bbfcf8a57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Joseph DiGiovanni <jdigiovanni78 at gmail dot com>
+
+pkgname=gnome-shell-extension-wireless-hid
+pkgver=15
+pkgrel=1
+
+source=("https://github.com/vchlum/wireless-hid/archive/refs/tags/${pkgver}.tar.gz")
+
+sha256sums=('e746778e1c8196fffef15d6878929fc07cf973d673b6adc65cc2d2a8b79f1c96')
+
+pkgdesc="Shows the battery of the wireless keyboards, mice, and game controllers"
+arch=('any')
+url="https://github.com/vchlum/wireless-hid"
+license=('GPL3')
+depends=('gnome-shell>=3.38')
+
+_extension_name="wireless-hid"
+
+build() {
+ cd "${srcdir}/${_extension_name}-${pkgver}"
+ make build
+}
+
+package() {
+ cd "${srcdir}/${_extension_name}-${pkgver}/build"
+ _uuid="${_extension_name}@chlumskyvaclav.gmail.com"
+ _install_dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+
+ install -d "${_install_dir}"
+ bsdtar -xvf "${_uuid}.zip" -C "${_install_dir}"
+
+ install -Dm644 "${_install_dir}/schemas/org.gnome.shell.extensions.${_extension_name}.gschema.xml" -t "${pkgdir}/usr/share/glib-2.0/schemas/"
+ install -Dm644 "${_install_dir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}