summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDriverXX2017-12-27 15:44:15 +0100
committerDriverXX2017-12-27 15:44:15 +0100
commit20f2633683b6d58cc89f3d6309f33057804a7605 (patch)
treedd78edf87d270853d79cbc0acd5e83424c6fcfea
parent5995ffb2a4ad1081897b590c3512cb0b81604d20 (diff)
downloadaur-20f2633683b6d58cc89f3d6309f33057804a7605.tar.gz
Update to v1.4.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD49
-rw-r--r--gnome-shell-extension-workspace-grid.install11
3 files changed, 22 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 085731f46841..84ad46afc5be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
-# Generated by mksrcinfo v8
-# Mon Apr 18 12:03:32 UTC 2016
pkgbase = gnome-shell-extension-workspace-grid
pkgdesc = Allows to configure your workspaces in a grid
- pkgver = 1.3.8.15
+ pkgver = 1.4.1
pkgrel = 1
- url = https://github.com/zakkak/workspace-grid-gnome-shell-extension
- install = gnome-shell-extension-workspace-grid.install
+ url = https://github.com/zakkak/workspace-grid
arch = any
license = GPL3
- makedepends = git
depends = gnome-shell
- source = gnome-shell-extension-workspace-grid::git+https://github.com/zakkak/workspace-grid-gnome-shell-extension.git
- sha256sums = SKIP
+ source = gnome-shell-extension-workspace-grid-1.4.1.tar.gz::https://github.com/zakkak/workspace-grid/archive/v1.4.1.tar.gz
+ sha512sums = 9a89da51b687d4f20003455760db7bd102ac4265073531a4781b824c6b130920a05164d65d81947d9a8331c209bc44fa9c69d17bfa5ae8ec9ac8607a3d97b923
pkgname = gnome-shell-extension-workspace-grid
diff --git a/PKGBUILD b/PKGBUILD
index c11f347cfc38..97cdf616b8f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,31 @@
-# Maintainer: Foivos S. Zakkak <foivos at zakkak dot net>
+# Maintainer: DriverX <thegio.f [at] gmail [dot] com>
+# Contributor: Foivos S. Zakkak <foivos at zakkak dot net>
# Contributor: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+_pkgname=workspace-grid
pkgname=gnome-shell-extension-workspace-grid
-pkgver=1.3.8.15
+pkgver=1.4.1
pkgrel=1
pkgdesc="Allows to configure your workspaces in a grid"
-arch=(any)
-url="https://github.com/zakkak/workspace-grid-gnome-shell-extension"
+arch=('any')
+url="https://github.com/zakkak/workspace-grid"
license=('GPL3')
depends=('gnome-shell')
-makedepends=('git')
-install=gnome-shell-extension-workspace-grid.install
-source=("$pkgname::git+https://github.com/zakkak/workspace-grid-gnome-shell-extension.git")
-sha256sums=('SKIP')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/zakkak/workspace-grid/archive/v$pkgver.tar.gz")
+sha512sums=('9a89da51b687d4f20003455760db7bd102ac4265073531a4781b824c6b130920a05164d65d81947d9a8331c209bc44fa9c69d17bfa5ae8ec9ac8607a3d97b923')
-pkgver() {
- cd "$pkgname"
- git describe --long | sed -r 's/^v//;s/([^-]*)-g.*$/\1/;s/-/./g'
+_uuid='workspace-grid@mathematical.coffee.gmail.com'
+
+build() {
+ cd "$srcdir/"$_pkgname-$pkgver
+ make
}
package() {
- cd "$pkgname"
- _uuid='workspace-grid@mathematical.coffee.gmail.com'
+ cd "$srcdir/"$_pkgname-$pkgver/$_uuid
+
+ install -dm 755 "$pkgdir"/usr/share/gnome-shell/extensions/$_uuid
+ install -Dm644 schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml "${pkgdir}"/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml
- install -Dm644 "${_uuid}/metadata.json" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
- install -m644 "${_uuid}/extension.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
- install -m644 "${_uuid}/convenience.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/convenience.js"
- install -m644 "${_uuid}/prefs.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
- install -m644 "${_uuid}/stylesheet.css" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/stylesheet.css"
- install -m644 "${_uuid}/ws-switch-arrow-left.png" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/ws-switch-arrow-left.png"
- install -m644 "${_uuid}/ws-switch-arrow-right.png" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/ws-switch-arrow-right.png"
- install -m644 "${_uuid}/myWorkspaceSwitcherPopup.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/myWorkspaceSwitcherPopup.js"
- install -Dm644 "${_uuid}/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml" \
- "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml"
+ cp -af * "${pkgdir}"/usr/share/gnome-shell/extensions/$_uuid
}
diff --git a/gnome-shell-extension-workspace-grid.install b/gnome-shell-extension-workspace-grid.install
deleted file mode 100644
index 8cd7bfd8ba3b..000000000000
--- a/gnome-shell-extension-workspace-grid.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- glib-compile-schemas usr/share/glib-2.0/schemas
-}
-
-post_upgrade() {
- glib-compile-schemas usr/share/glib-2.0/schemas
-}
-
-post_remove() {
- glib-compile-schemas usr/share/glib-2.0/schemas
-}