summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFoivos S. Zakkak2015-07-07 19:55:41 +0300
committerFoivos S. Zakkak2015-07-07 19:55:41 +0300
commitbbfda47ef319ad58e5baaa1b93b399fb43fd6987 (patch)
tree6b812804c04035e042beb64ed3e25a3b02dacbcd
downloadaur-bbfda47ef319ad58e5baaa1b93b399fb43fd6987.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
-rw-r--r--gnome-shell-extension-workspace-grid.install11
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c336284400d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-workspace-grid
+ pkgdesc = Allows to configure your workspaces in a grid
+ pkgver = 1.3.4.r0.g22b96b2
+ pkgrel = 1
+ url = https://github.com/zakkak/workspace-grid-gnome-shell-extension
+ install = gnome-shell-extension-workspace-grid.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-workspace-grid::git+https://github.com/zakkak/workspace-grid-gnome-shell-extension.git#tag=v1.3.4
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-workspace-grid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f44168a332b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Foivos S. Zakkak <foivos at zakkak dot net>
+# Contributor: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+
+pkgname=gnome-shell-extension-workspace-grid
+pkgver=1.3.4.r0.g22b96b2
+pkgrel=1
+pkgdesc="Allows to configure your workspaces in a grid"
+arch=('i686' 'x86_64')
+url="https://github.com/zakkak/workspace-grid-gnome-shell-extension"
+license=('unknown')
+depends=('gnome-shell')
+makedepends=('git')
+install=gnome-shell-extension-workspace-grid.install
+source=("$pkgname::git+https://github.com/zakkak/workspace-grid-gnome-shell-extension.git#tag=v1.3.4")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ _uuid='workspace-grid@mathematical.coffee.gmail.com'
+
+ install -Dm644 "${_uuid}/metadata.json" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
+ install -m644 "${_uuid}/extension.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+ install -m644 "${_uuid}/convenience.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/convenience.js"
+ install -m644 "${_uuid}/prefs.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
+ install -m644 "${_uuid}/stylesheet.css" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/stylesheet.css"
+ install -m644 "${_uuid}/ws-switch-arrow-left.png" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/ws-switch-arrow-left.png"
+ install -m644 "${_uuid}/ws-switch-arrow-right.png" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/ws-switch-arrow-right.png"
+ install -Dm644 "${_uuid}/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml"
+}
diff --git a/gnome-shell-extension-workspace-grid.install b/gnome-shell-extension-workspace-grid.install
new file mode 100644
index 000000000000..8cd7bfd8ba3b
--- /dev/null
+++ b/gnome-shell-extension-workspace-grid.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}