summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-04-11 08:46:38 +0430
committerMohammadreza Abdollahzadeh2017-04-11 08:46:38 +0430
commitb8495016b975a6aa490a44530ec364a1423273c5 (patch)
treeb354d4e65b0e27e6b12cd16803342649b64fbd39
parentc4a6ff0ac26b419963cedc3f6c4126a57e57b42b (diff)
downloadaur-b8495016b975a6aa490a44530ec364a1423273c5.tar.gz
fix PKGBUILD and version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd91aa788124..3bbbbad046b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
# Generated by mksrcinfo v8
-# Wed May 25 06:32:35 UTC 2016
+# Tue Apr 11 04:15:59 UTC 2017
pkgbase = gnome-shell-extension-workspaces-to-dock
pkgdesc = Gnome shell extension, Workspaces to Dock, Transform Gnome Shell's overview workspaces into an intelligent dock.
- pkgver = r561.4ba99b3
+ pkgver = 41_3.24.r0.ga544f98
pkgrel = 1
url = https://extensions.gnome.org/extension/427/workspaces-to-dock/
arch = any
groups = gnome-shell-extensions
license = GPL
+ makedepends = git
+ makedepends = gnome-common
depends = gnome-shell
source = git+https://github.com/passingthru67/workspaces-to-dock.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c968091170c5..de36fc0863f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Nabil Freij <nabil.freij@gmail.com>
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributors: Nabil Freij <nabil.freij@gmail.com>
pkgname=gnome-shell-extension-workspaces-to-dock
-pkgver=r561.4ba99b3
+pkgver=41_3.24.r0.ga544f98
pkgrel=1
pkgdesc="Gnome shell extension, Workspaces to Dock, Transform Gnome Shell's overview workspaces into an intelligent dock."
arch=('any')
@@ -9,13 +10,13 @@ url="https://extensions.gnome.org/extension/427/workspaces-to-dock/"
license=('GPL')
depends=('gnome-shell')
groups=('gnome-shell-extensions')
-akedepends=('git' 'gnome-common')
+makedepends=('git' 'gnome-common')
source=("git+https://github.com/passingthru67/workspaces-to-dock.git")
md5sums=('SKIP')
pkgver() {
cd "$srcdir/workspaces-to-dock"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/workspaces-to-dock.v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -25,6 +26,6 @@ build() {
package() {
cd "$srcdir/workspaces-to-dock"
- mkdir -p "$pkgdir/usr/share/gnome-shell/extensions"
- cp -r "workspaces-to-dock@passingthru67.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions/"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -a "workspaces-to-dock@passingthru67.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions/"
}