summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorr3b311i0n2017-10-09 20:38:49 +0530
committerr3b311i0n2017-10-09 20:38:49 +0530
commitf2cae6d5e52f8fe7f03fe6ce9504448c0140b8e8 (patch)
tree6ca3d761698c0c805ba413363653bc736bd7fe16
parentb8495016b975a6aa490a44530ec364a1423273c5 (diff)
downloadaur-f2cae6d5e52f8fe7f03fe6ce9504448c0140b8e8.tar.gz
Change from git devel package to release packages
Update to v44_3.26
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 22 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bbbbad046b7..ed98eabdeab9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
-# Generated by mksrcinfo v8
-# Tue Apr 11 04:15:59 UTC 2017
pkgbase = gnome-shell-extension-workspaces-to-dock
pkgdesc = Gnome shell extension, Workspaces to Dock, Transform Gnome Shell's overview workspaces into an intelligent dock.
- pkgver = 41_3.24.r0.ga544f98
+ pkgver = 44_3.26
pkgrel = 1
- url = https://extensions.gnome.org/extension/427/workspaces-to-dock/
+ url = https://github.com/passingthru67/workspaces-to-dock
arch = any
- groups = gnome-shell-extensions
- license = GPL
- makedepends = git
- makedepends = gnome-common
- depends = gnome-shell
- source = git+https://github.com/passingthru67/workspaces-to-dock.git
- md5sums = SKIP
+ license = GPL3
+ depends = gnome-shell>=3.26
+ conflicts = workspaces-to-dock-git
+ source = https://github.com/passingthru67/workspaces-to-dock/archive/workspaces-to-dock.v44_3.26.tar.gz
+ sha256sums = adabf07456e75673eaa01147cf6f2f87bbd7ee88e22d07491eb314fc24730ad1
pkgname = gnome-shell-extension-workspaces-to-dock
diff --git a/PKGBUILD b/PKGBUILD
index de36fc0863f0..e819e59247f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,27 @@
-# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
-# Contributors: Nabil Freij <nabil.freij@gmail.com>
+# Maintainer: Amal Karunarathna <nasashinega@gmail.com>
+# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+# Contributor: Nabil Freij <nabil.freij@gmail.com>
pkgname=gnome-shell-extension-workspaces-to-dock
-pkgver=41_3.24.r0.ga544f98
+_gitname=workspaces-to-dock
+pkgver=44_3.26
pkgrel=1
pkgdesc="Gnome shell extension, Workspaces to Dock, Transform Gnome Shell's overview workspaces into an intelligent dock."
arch=('any')
-url="https://extensions.gnome.org/extension/427/workspaces-to-dock/"
-license=('GPL')
-depends=('gnome-shell')
-groups=('gnome-shell-extensions')
-makedepends=('git' 'gnome-common')
-source=("git+https://github.com/passingthru67/workspaces-to-dock.git")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/workspaces-to-dock"
- git describe --long | sed 's/workspaces-to-dock.v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
+url="https://github.com/passingthru67/workspaces-to-dock"
+license=('GPL3')
+depends=('gnome-shell>=3.26')
+conflicts=("${_gitname}-git")
+source=("https://github.com/passingthru67/${_gitname}/archive/${_gitname}.v${pkgver}.tar.gz")
+sha256sums=('adabf07456e75673eaa01147cf6f2f87bbd7ee88e22d07491eb314fc24730ad1')
build() {
- cd "$srcdir/workspaces-to-dock"
+ cd "${srcdir}/${_gitname}-${_gitname}.v${pkgver}"
glib-compile-schemas "workspaces-to-dock@passingthru67.gmail.com/schemas/"
}
package() {
- cd "$srcdir/workspaces-to-dock"
- install -d "$pkgdir/usr/share/gnome-shell/extensions"
- cp -a "workspaces-to-dock@passingthru67.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions/"
+ cd "${srcdir}/${_gitname}-${_gitname}.v${pkgver}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -a "workspaces-to-dock@passingthru67.gmail.com" "${pkgdir}/usr/share/gnome-shell/extensions/"
}