summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-04-11 08:58:25 +0430
committerMohammadreza Abdollahzadeh2017-04-11 08:58:25 +0430
commitdebbffe724271d61186cbec8705cb6bc3951455b (patch)
treea1aa5628a0fabc9100917facafbf14e3714563f4
downloadaur-debbffe724271d61186cbec8705cb6bc3951455b.tar.gz
initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9577438432e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Apr 11 04:28:08 UTC 2017
+pkgbase = gnome-shell-extension-workspaces-to-dock-git
+ pkgdesc = Gnome shell extension, Workspaces to Dock, Transform Gnome Shell's overview workspaces into an intelligent dock.
+ pkgver = 41_3.24.r0.ga544f98
+ pkgrel = 1
+ url = https://github.com/passingthru67/workspaces-to-dock
+ arch = any
+ groups = gnome-shell-extensions
+ license = GPL
+ makedepends = git
+ makedepends = gnome-common
+ depends = gnome-shell
+ provides = gnome-shell-extension-workspaces-to-dock
+ conflicts = gnome-shell-extension-workspaces-to-dock
+ replaces = gnome-shell-extension-workspaces-to-dock
+ source = git+https://github.com/passingthru67/workspaces-to-dock.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-workspaces-to-dock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..617ff7afcf56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=gnome-shell-extension-workspaces-to-dock-git
+pkgver=41_3.24.r0.ga544f98
+pkgrel=1
+pkgdesc="Gnome shell extension, Workspaces to Dock, Transform Gnome Shell's overview workspaces into an intelligent dock."
+arch=('any')
+url="https://github.com/passingthru67/workspaces-to-dock"
+license=('GPL')
+groups=('gnome-shell-extensions')
+depends=('gnome-shell')
+makedepends=('git' 'gnome-common')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+source=("git+https://github.com/passingthru67/workspaces-to-dock.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/workspaces-to-dock"
+ git describe --long | sed 's/workspaces-to-dock.v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/workspaces-to-dock"
+ glib-compile-schemas "workspaces-to-dock@passingthru67.gmail.com/schemas/"
+}
+
+package() {
+ cd "$srcdir/workspaces-to-dock"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -a "workspaces-to-dock@passingthru67.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions/"
+}