summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgabrielstedman2017-02-28 13:24:58 +0000
committergabrielstedman2017-02-28 13:24:58 +0000
commit212f7aef413c65cc0e1df9514c0862d850ac824d (patch)
treeae556a590cdbe3084ebf29b3a1bb1227da780be3
parentc2a960debd4d019d693941951bc374e74ee97bb2 (diff)
downloadaur-212f7aef413c65cc0e1df9514c0862d850ac824d.tar.gz
Update to 1.1.5_all
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xupdate_package18
3 files changed, 24 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06c2e35a348f..9a4f848be4a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Nov 21 13:21:46 UTC 2016
+# Tue Feb 28 13:24:54 UTC 2017
pkgbase = gnome-shell-extension-zorin-dash
pkgdesc = Various settings and changes for the dash in Zorin Desktop.
- pkgver = 1.0.9
+ pkgver = 1.1.5_all
pkgrel = 1
url = http://zorinos.com/
install = gnome-shell-extension-zorin-dash.install
@@ -12,8 +12,8 @@ pkgbase = gnome-shell-extension-zorin-dash
depends = gnome-shell
options = !emptydirs
options = !strip
- source = http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-dash/gnome-shell-extension-zorin-dash_1.0.9_all.deb
- md5sums = 8c9b1d2055d681b56f5cf942f256b3ae
+ source = http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-dash/gnome-shell-extension-zorin-dash_1.1.5_all.deb
+ md5sums = 65a30424642f74d93dd8cb09eae30f9d
pkgname = gnome-shell-extension-zorin-dash
diff --git a/PKGBUILD b/PKGBUILD
index 38b8235c9652..bfa7676da9a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=gnome-shell-extension-zorin-dash
-pkgver=1.0.9
+pkgver=1.1.5_all
pkgrel=1
pkgdesc="Various settings and changes for the dash in Zorin Desktop."
arch=('i686' 'x86_64')
@@ -8,8 +8,8 @@ license=('GPL-2+')
depends=('gnome-shell')
options=('!emptydirs' '!strip')
install=${pkgname}.install
-source=("http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-dash/gnome-shell-extension-zorin-dash_${pkgver}_all.deb")
-md5sums=('8c9b1d2055d681b56f5cf942f256b3ae')
+source=('http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-dash/gnome-shell-extension-zorin-dash_1.1.5_all.deb')
+md5sums=('65a30424642f74d93dd8cb09eae30f9d')
package() {
msg2 "Extracting the data.tar.xz..."
diff --git a/update_package b/update_package
index c66f014f0a0b..a4b13a465e77 100755
--- a/update_package
+++ b/update_package
@@ -1,4 +1,9 @@
#!/bin/bash
+
+function commit_all(){
+ latest_version=$1
+
+}
set -e
current_package=$(cat PKGBUILD | grep pkgname= | cut -d'=' -f2)
curl_line=$(curl -qL http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/$current_package | grep .deb)
@@ -14,4 +19,15 @@ echo $md5s
# Update
sed -i "s/pkgver=.*/pkgver=$latest_version/g" PKGBUILD
sed -i "s,source=.*,source=(\'$deb_url\'),g" PKGBUILD
-sed -i "s/md5sums=.*/md5sums=(\'$md5s\')/g" PKGBUILD \ No newline at end of file
+sed -i "s/md5sums=.*/md5sums=(\'$md5s\')/g" PKGBUILD
+mksrcinfo
+
+cat PKGBUILD
+git status
+echo "Do you wish to commit?"
+read -r answer
+if echo "$answer" | grep -iq "^y" ;then
+ git add -vA
+ git commit -vm "Update to $latest_version"
+ git -v push origin master
+fi \ No newline at end of file