summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgabriel2016-10-14 09:55:45 +0100
committergabriel2016-10-14 09:55:45 +0100
commitad601ad13f1facca97f323f99e9df4b104407674 (patch)
treef3bec5f242ef9d60a8463d3eef772de758f4c56d
downloadaur-ad601ad13f1facca97f323f99e9df4b104407674.tar.gz
First port
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
-rw-r--r--gnome-shell-extension-zorin-dash.install17
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cae7d07e76a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-zorin-dash
+ pkgdesc = Various settings and changes for the dash in Zorin Desktop.
+ pkgver = 1.0.8
+ pkgrel = 1
+ url = http://zorinos.com/
+ install = gnome-shell-extension-zorin-dash.install
+ arch = i686
+ arch = x86_64
+ license = GPL-2+
+ depends = gnome-shell
+ options = !emptydirs
+ options = !strip
+ source = http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-dash/gnome-shell-extension-zorin-dash_1.0.8_all.deb
+ md5sums = ad771141bcc7b1e811a2b3e49375158a
+
+pkgname = gnome-shell-extension-zorin-dash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..056829816ac2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=gnome-shell-extension-zorin-dash
+pkgver=1.0.8
+pkgrel=1
+pkgdesc="Various settings and changes for the dash in Zorin Desktop."
+arch=('i686' 'x86_64')
+url="http://zorinos.com/"
+license=('GPL-2+')
+depends=('gnome-shell')
+options=('!emptydirs' '!strip')
+install=${pkgname}.install
+source=("http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-dash/gnome-shell-extension-zorin-dash_${pkgver}_all.deb")
+md5sums=('ad771141bcc7b1e811a2b3e49375158a')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}
+
diff --git a/gnome-shell-extension-zorin-dash.install b/gnome-shell-extension-zorin-dash.install
new file mode 100644
index 000000000000..13eccced9b4f
--- /dev/null
+++ b/gnome-shell-extension-zorin-dash.install
@@ -0,0 +1,17 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ echo "==============================================================="
+ echo "To use the extension:"
+ echo " * Restart GNOME Shell ([Alt]+[F2], r)"
+ echo " * Activate it (eg using gnome-tweak-tool)"
+ echo "==============================================================="
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+