summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgabriel2016-10-14 09:51:53 +0100
committergabriel2016-10-14 09:51:53 +0100
commit139862a849b5cdb10848a67e4071bc90e61fca96 (patch)
tree15a5593430f276e7d26f0856762528ad52e28742
downloadaur-139862a849b5cdb10848a67e4071bc90e61fca96.tar.gz
First port
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
-rw-r--r--gnome-shell-extension-zorin-taskbar.install17
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59bb5aa74b98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-zorin-taskbar
+ pkgdesc = Various settings and changes for the panel in Zorin Desktop.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://zorinos.com/
+ install = gnome-shell-extension-zorin-taskbar.install
+ arch = i686
+ arch = x86_64
+ license = GPL-2+
+ depends = gnome-shell
+ options = !emptydirs
+ options = !strip
+ source = http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-taskbar/gnome-shell-extension-zorin-taskbar_1.0.2_all.deb
+ md5sums = 8ba5050ca2fea9d1e21d3fd589efa775
+
+pkgname = gnome-shell-extension-zorin-taskbar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65f9534cd3a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+pkgname=gnome-shell-extension-zorin-taskbar
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Various settings and changes for the panel in Zorin Desktop."
+arch=('i686' 'x86_64')
+url="http://zorinos.com/"
+license=('GPL-2+')
+depends=('gnome-shell')
+options=('!emptydirs' '!strip')
+install=${pkgname}.install
+source=("http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-taskbar/gnome-shell-extension-zorin-taskbar_${pkgver}_all.deb")
+md5sums=('8ba5050ca2fea9d1e21d3fd589efa775')
+
+package() {
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -xf data.tar.xz -C "$pkgdir/"
+}
+
diff --git a/gnome-shell-extension-zorin-taskbar.install b/gnome-shell-extension-zorin-taskbar.install
new file mode 100644
index 000000000000..13eccced9b4f
--- /dev/null
+++ b/gnome-shell-extension-zorin-taskbar.install
@@ -0,0 +1,17 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ echo "==============================================================="
+ echo "To use the extension:"
+ echo " * Restart GNOME Shell ([Alt]+[F2], r)"
+ echo " * Activate it (eg using gnome-tweak-tool)"
+ echo "==============================================================="
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+