summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-02 10:22:10 +0200
committerPellegrino Prevete2023-07-02 10:22:10 +0200
commit78f5a5c08671a045838884d491b9aad7a178f23d (patch)
treeaca2e104bec67654bfac36ad491db0a4028e6f07
parent753cfc8632bc5fb092ebd9cec827b92231d07862 (diff)
downloadaur-gnome-shell-extensions-git.tar.gz
update to 44
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD57
2 files changed, 46 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d204d646260f..f798a3b2d0d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = gnome-shell-extensions-git
pkgdesc = Extensions for GNOME shell, including classic mode
- pkgver = 40.0+7+ge094dea
+ pkgver = 44.0+7+gb7895ad
pkgrel = 1
url = https://wiki.gnome.org/Projects/GnomeShell/Extensions
arch = any
+ groups = gnome
license = GPL
+ makedepends = git
makedepends = meson
makedepends = git
makedepends = sassc
- makedepends = js78
+ depends = gnome-shell
optdepends = gnome-menus: applications menu extension
- provides = gnome-shell-extensions
+ provides = gnome-shell-extensions=44.0+7+gb7895ad
conflicts = gnome-shell-extensions
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell-extensions.git
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell-extensions
source = git+https://gitlab.gnome.org/GNOME/gnome-shell-sass.git
b2sums = SKIP
b2sums = SKIP
pkgname = gnome-shell-extensions-git
- depends = gnome-shell
diff --git a/PKGBUILD b/PKGBUILD
index 7acd03da642b..aee35b599ce7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,59 @@
-pkgname=gnome-shell-extensions-git
-_pkgname=gnome-shell-extensions
-pkgver=40.0+7+ge094dea
+# Maintainer: Pellegrino Prevet (tallero)
+
+_pkg="gnome-shell"
+_pkgname="${_pkg}-extensions"
+pkgname="${_pkgname}-git"
+pkgver=44.0+7+gb7895ad
pkgrel=1
pkgdesc="Extensions for GNOME shell, including classic mode"
url="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
arch=(any)
license=(GPL)
-makedepends=('meson' 'git' 'sassc' 'js78')
-optdepends=('gnome-menus: applications menu extension')
-provides=('gnome-shell-extensions')
-conflicts=('gnome-shell-extensions')
-source=("git+https://gitlab.gnome.org/GNOME/gnome-shell-extensions.git"
- "git+https://gitlab.gnome.org/GNOME/gnome-shell-sass.git")
+depends=(
+ "${_pkg}"
+)
+makedepends=(
+ git
+ meson
+ git
+ sassc
+)
+optdepends=(
+ 'gnome-menus: applications menu extension'
+)
+groups=(gnome)
+provides=(
+ "${_pkgname}=${pkgver}"
+)
+conflicts=(
+ "${_pkgname}"
+)
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}"
+ "git+https://gitlab.gnome.org/GNOME/${_pkg}-sass.git")
b2sums=('SKIP'
'SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd $_pkgname
+ cd "${_pkgname}"
git submodule init
- git config --local submodule.data/gnome-shell-sass.url "$srcdir/gnome-shell-sass"
+ git config --local "submodule.data/${_pkg}-sass.url" \
+ "${srcdir}/${_pkg}-sass"
git submodule update
}
build() {
- arch-meson $_pkgname build -D extension_set=all -D classic_mode=true
- ninja -C build
+ local meson_options=(
+ -D extension_set=all
+ -D classic_mode=true
+ )
+ arch-meson "${_pkgname}" build "${meson_options[@]}"
+ meson compile -C build
}
check() {
@@ -38,7 +61,7 @@ check() {
}
package() {
- depends=(gnome-shell)
-
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "${pkgdir}"
}
+
+# vim:set sw=2 sts=-1 et: