summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrliang2019-01-10 11:25:23 -0200
committerrliang2019-01-10 11:25:23 -0200
commit7393d712489e361de2961f5014a9ced3b4e1120c (patch)
tree0d267321406152ee9c3502cbd302139c4c2e18e8
downloadaur-7393d712489e361de2961f5014a9ced3b4e1120c.tar.gz
Initial commit
-rw-r--r--.SRCINFO45
-rw-r--r--PKGBUILD53
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..287ccce94c0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+pkgbase = gnome-shell-git
+ pkgdesc = Next generation desktop shell
+ pkgver = 3.31.2+40+g3989cad3d
+ pkgrel = 1
+ epoch = 1
+ url = https://wiki.gnome.org/Projects/GnomeShell
+ arch = x86_64
+ groups = gnome
+ license = GPL2
+ makedepends = gtk-doc
+ makedepends = gnome-control-center
+ makedepends = evolution-data-server
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ makedepends = sassc
+ depends = accountsservice
+ depends = gcr
+ depends = gjs
+ depends = gnome-bluetooth
+ depends = upower
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gnome-themes-extra
+ depends = gsettings-desktop-schemas
+ depends = libcanberra-pulse
+ depends = libcroco
+ depends = libgdm
+ depends = libsecret
+ depends = mutter-git
+ depends = nm-connection-editor
+ depends = unzip
+ depends = gstreamer
+ depends = libibus
+ optdepends = gnome-control-center: System settings
+ optdepends = evolution-data-server: Evolution calendar integration
+ provides = gnome-shell
+ conflicts = gnome-shell
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git
+ source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gnome-shell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..798b45d2f67c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Ricardo Liang (rliang) <ricardoliang@gmail.com>
+
+_pkgname=gnome-shell
+pkgname="$_pkgname"-git
+pkgver=3.31.2+40+g3989cad3d
+pkgrel=1
+epoch=1
+pkgdesc="Next generation desktop shell"
+url="https://wiki.gnome.org/Projects/GnomeShell"
+arch=(x86_64)
+license=(GPL2)
+provides=(gnome-shell)
+conflicts=(gnome-shell)
+depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
+ gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
+ mutter-git nm-connection-editor unzip gstreamer libibus)
+makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
+ sassc)
+optdepends=('gnome-control-center: System settings'
+ 'evolution-data-server: Evolution calendar integration')
+groups=(gnome)
+source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
+sha256sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+
+ # Move the plugin to our custom epiphany-only dir
+ sed -i "s/'mozilla'/'epiphany'/g" meson.build
+
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
+}
+
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+
+ # https://bugs.archlinux.org/task/37412
+ mkdir "$pkgdir/usr/share/gnome-shell/modes"
+}