summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Gardling2020-02-29 19:03:22 -0500
committerSimon Gardling2020-02-29 19:03:22 -0500
commit75d55ae41f5f45d83e22ec15e808093f893b3b97 (patch)
tree15c9c430aa9bbba5d0335b1e930fefd4bce04b79
parent6485899c3b1064df3a8156fe12481eb920544fb2 (diff)
downloadaur-75d55ae41f5f45d83e22ec15e808093f893b3b97.tar.gz
update version and dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD38
2 files changed, 17 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57df4a128c17..eb6f7ea29815 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = gnome-shell-git
pkgdesc = Next generation desktop shell
- pkgver = 3.31.2+40+g3989cad3d
+ pkgver = 3.35.91+109+g648179a2d
pkgrel = 1
epoch = 1
- url = https://wiki.gnome.org/Projects/GnomeShell
+ url = https://gitlab.gnome.org/GNOME/gnome-shell
arch = x86_64
groups = gnome
license = GPL2
@@ -14,13 +14,16 @@ pkgbase = gnome-shell-git
makedepends = git
makedepends = meson
makedepends = sassc
+ makedepends = asciidoc
depends = accountsservice
depends = gcr
- depends = gjs
+ depends = gjs-dev
+ depends = js68
depends = gnome-bluetooth
depends = upower
depends = gnome-session
depends = gnome-settings-daemon
+ depends = sysprof-dev
depends = gnome-themes-extra
depends = gsettings-desktop-schemas
depends = libcanberra-pulse
@@ -36,10 +39,7 @@ pkgbase = gnome-shell-git
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
conflicts = gnome-shell
- conflicts = gnome-shell-dev
source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git
- source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- sha256sums = SKIP
sha256sums = SKIP
pkgname = gnome-shell-git
diff --git a/PKGBUILD b/PKGBUILD
index ee5d271e97b7..6904f797fb3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,37 @@
-# Maintainer: Ricardo Liang (rliang) <ricardoliang@gmail.com>
+# Maintainer: Simon Gardling <titaniumtown@gmail.com>
+pkgname=gnome-shell-git
_pkgname=gnome-shell
-pkgname="$_pkgname"-git
-pkgver=3.31.2+40+g3989cad3d
+pkgver=3.35.91+109+g648179a2d
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
-url="https://wiki.gnome.org/Projects/GnomeShell"
+url="https://gitlab.gnome.org/GNOME/gnome-shell"
arch=(x86_64)
license=(GPL2)
-provides=(gnome-shell)
-conflicts=(gnome-shell gnome-shell-dev)
-depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
+depends=(accountsservice gcr gjs-dev js68 gnome-bluetooth upower gnome-session gnome-settings-daemon sysprof-dev
gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
mutter-git nm-connection-editor unzip gstreamer libibus)
makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
- sassc)
+ sassc asciidoc)
optdepends=('gnome-control-center: System settings'
'evolution-data-server: Evolution calendar integration')
groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
-sha256sums=('SKIP'
- 'SKIP')
+provides=(gnome-shell)
+conflicts=(gnome-shell)
+source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git")
+sha256sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's/-/+/g'
}
-prepare() {
- cd $_pkgname
-
- # Move the plugin to our custom epiphany-only dir
- sed -i "s/'mozilla'/'epiphany'/g" meson.build
-
- git submodule init
- git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
- git submodule update
-}
-
build() {
- arch-meson $_pkgname build -D gtk_doc=true
+ arch-meson "$_pkgname" build -D gtk_doc=true
ninja -C build
}
package() {
DESTDIR="$pkgdir" meson install -C build
-
- # https://bugs.archlinux.org/task/37412
- mkdir "$pkgdir/usr/share/gnome-shell/modes"
}