summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-23 23:47:48 +0200
committerPellegrino Prevete2023-06-23 23:47:48 +0200
commitcf3619425d7deb966d95488b788b9933ef020749 (patch)
tree6d424af308900c126aa2fc549dc5f6edf4e19c5a
parentc579d2f36bb2b0bafe90fad7c89cc08ad569d6a0 (diff)
downloadaur-cf3619425d7deb966d95488b788b9933ef020749.tar.gz
update towards 45
-rw-r--r--.SRCINFO78
-rw-r--r--PKGBUILD114
2 files changed, 150 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fdbcdab042a..7d60fecd1d18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,51 +1,81 @@
pkgbase = gnome-shell-git
pkgdesc = Next generation desktop shell
- pkgver = 43.0+17+g901661487
+ pkgver = 44.1+116+gace8676ad
pkgrel = 1
epoch = 1
- url = https://gitlab.gnome.org/GNOME/gnome-shell
+ url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
arch = i686
arch = pentium4
+ arch = aarch64
+ arch = armv7h
+ arch = armv6l
groups = gnome
license = GPL
- makedepends = gtk-doc
+ checkdepends = appstream-glib
+ checkdepends = python-dbusmock
+ checkdepends = xorg-server-xvfb
+ makedepends = asciidoc
+ makedepends = bash-completion
+ makedepends = evolution-data-server
+ makedepends = git
makedepends = gnome-control-center
- makedepends = evolution-data-server-git
makedepends = gobject-introspection
- makedepends = git
+ makedepends = gtk-doc
makedepends = meson
makedepends = sassc
- makedepends = asciidoc
- makedepends = bash-completion
- makedepends = vulkan-headers
depends = accountsservice
- depends = gcr-git
- depends = gjs-git
- depends = gnome-bluetooth
- depends = upower
+ depends = gcr-4
+ depends = gjs
+ depends = gnome-autoar
depends = gnome-session
- depends = gtk4
depends = gnome-settings-daemon
- depends = gsettings-desktop-schemas-git
+ depends = gsettings-desktop-schemas
+ depends = gtk4
+ depends = libadwaita
depends = libcanberra-pulse
depends = libgdm
+ depends = libgweather-4
+ depends = libibus
+ depends = libnma-gtk4
depends = libsecret
- depends = mutter-git
- depends = nm-connection-editor
+ depends = libsoup3
+ depends = mutter
depends = unzip
- depends = gstreamer
- depends = libibus
- depends = gnome-autoar
- depends = gnome-disk-utility
- depends = gst-plugin-pipewire
- depends = libsoup3-git
- depends = libgweather-git
- optdepends = gnome-control-center: System settings
+ depends = upower
optdepends = evolution-data-server: Evolution calendar integration
+ optdepends = gnome-bluetooth-3.0: Bluetooth support
+ optdepends = gnome-control-center: System settings
+ optdepends = gnome-disk-utility: Mount with keyfiles
+ optdepends = gst-plugin-pipewire: Screen recording
+ optdepends = gst-plugins-good: Screen recording
+ optdepends = power-profiles-daemon: Power profile switching
+ optdepends = switcheroo-control: Multi-GPU support
provides = gnome-shell
conflicts = gnome-shell
source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git
+ source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = gnome-shell-git
+ depends = accountsservice
+ depends = gcr-4
+ depends = gjs
+ depends = gnome-autoar
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gsettings-desktop-schemas
+ depends = gtk4
+ depends = libadwaita
+ depends = libcanberra-pulse
+ depends = libgdm
+ depends = libgweather-4
+ depends = libibus
+ depends = libnma-gtk4
+ depends = libsecret
+ depends = libsoup3
+ depends = mutter
+ depends = unzip
+ depends = upower
+ depends = libgnome-shell-12.so
diff --git a/PKGBUILD b/PKGBUILD
index ac9521501964..1718005d2721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,42 +3,120 @@
# Contributor: Simon Gardling <titaniumtown@gmail.com>
# Contributor: Ricardo Liang (rliang) <ricardoliang@gmail.com>
-# shellcheck disable=SC2034
_pkgname="gnome-shell"
pkgname="${_pkgname}-git"
-pkgver=43.0+17+g901661487
+pkgver=44.1+116+gace8676ad
pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
-url="https://gitlab.gnome.org/GNOME/${_pkgname}"
-arch=('x86_64' 'i686' 'pentium4')
+url="https://wiki.gnome.org/Projects/GnomeShell"
+arch=(
+ 'x86_64'
+ 'i686'
+ 'pentium4'
+ 'aarch64'
+ 'armv7h'
+ 'armv6l')
license=(GPL)
-depends=(accountsservice gcr-git gjs-git gnome-bluetooth upower gnome-session gtk4
- gnome-settings-daemon gsettings-desktop-schemas-git libcanberra-pulse
- libgdm libsecret mutter-git nm-connection-editor unzip gstreamer libibus
- gnome-autoar gnome-disk-utility gst-plugin-pipewire libsoup3-git libgweather-git)
-makedepends=(gtk-doc gnome-control-center evolution-data-server-git
- gobject-introspection git meson sassc asciidoc bash-completion
- vulkan-headers)
-optdepends=('gnome-control-center: System settings'
- 'evolution-data-server: Evolution calendar integration')
+depends=(
+ accountsservice
+ gcr-4
+ gjs
+ gnome-autoar
+ gnome-session
+ gnome-settings-daemon
+ gsettings-desktop-schemas
+ gtk4
+ libadwaita
+ libcanberra-pulse
+ libgdm
+ libgweather-4
+ libibus
+ libnma-gtk4
+ libsecret
+ libsoup3
+ mutter
+ unzip
+ upower
+)
+makedepends=(
+ asciidoc
+ bash-completion
+ evolution-data-server
+ git
+ gnome-control-center
+ gobject-introspection
+ gtk-doc
+ meson
+ sassc
+)
+checkdepends=(
+ appstream-glib
+ python-dbusmock
+ xorg-server-xvfb
+)
+optdepends=(
+ 'evolution-data-server: Evolution calendar integration'
+ 'gnome-bluetooth-3.0: Bluetooth support'
+ 'gnome-control-center: System settings'
+ 'gnome-disk-utility: Mount with keyfiles'
+ 'gst-plugin-pipewire: Screen recording'
+ 'gst-plugins-good: Screen recording'
+ 'power-profiles-daemon: Power profile switching'
+ 'switcheroo-control: Multi-GPU support'
+)
groups=(gnome)
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
-sha256sums=('SKIP')
+_project_url="https://gitlab.gnome.org/GNOME"
+_repo_url="${_project_url}/${_pkgname}"
+_gvc_repo_url="${_project_url}/libgnome-volume-control"
+source=("git+${_repo_url}.git"
+ "git+${_gvc_repo_url}.git")
+sha256sums=(
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "${_pkgname}" || exit
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd $"${_pkgname}"
+
+ git submodule init
+ git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
- arch-meson "$_pkgname" build -D gtk_doc=true
+ local meson_options=(
+ -D gtk_doc=true
+ )
+
+ CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
+ LDFLAGS+=" -Wl,-Bsymbolic-functions"
+
+ arch-meson "${_pkgname}" build "${meson_options[@]}"
meson compile -C build
}
-# shellcheck disable=SC2154
+_check() (
+ export XDG_RUNTIME_DIR="$PWD/rdir"
+ mkdir -p -m 700 "$XDG_RUNTIME_DIR"
+
+ meson test -C build --print-errorlogs -t 3
+)
+
+check() {
+ dbus-run-session xvfb-run -s '-nolisten local +iglx -noreset' \
+ bash -c "$(declare -f _check); _check"
+}
+
package() {
- DESTDIR="$pkgdir" meson install -C build
+ depends+=("lib${_pkgname}-12.so")
+ meson install -C build --destdir "${pkgdir}"
}
+
+# vim:set sw=2 sts=-1 et: