summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Quinn2015-08-10 01:42:12 +0100
committerTobias Quinn2015-08-10 01:42:50 +0100
commit84c65936b39bb21d152c8781ba38709d77c34577 (patch)
tree656d1066ca0a575298a22913d90bfe50797bade8
downloadaur-84c65936b39bb21d152c8781ba38709d77c34577.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--gnome-shell-mousewheel-zoom.install11
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee4a1de1f27b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-mousewheel-zoom
+ pkgdesc = Enable mousewheel zoom using left-alt key using gnome-shell
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://github.com/tobiasquinn/gnome-shell-mousewheel-zoom
+ install = gnome-shell-mousewheel-zoom.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ depends = gnome-shell
+ provides = gnome-shell-mousewheel-zoom
+ conflicts = gnome-shell-mousewheel-zoom-git
+ source = gnome-shell-mousewheel-zoom_0.8.0.tar.gz::https://github.com/tobiasquinn/gnome-shell-mousewheel-zoom/tarball/upstream/0.8.0
+ md5sums = 6fd73ac036c8e6d2a499d28df52fdcb5
+
+pkgname = gnome-shell-mousewheel-zoom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb49e5c95d76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Author: Tobias Quinn <tobias@tobiasquinn.com>
+# Maintainer: Tobias Quinn <tobias@tobiasquinn.com>
+pkgname=gnome-shell-mousewheel-zoom
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Enable mousewheel zoom using left-alt key using gnome-shell"
+arch=('i686' 'x86_64')
+url="https://github.com/tobiasquinn/gnome-shell-mousewheel-zoom"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('vala')
+conflicts=('gnome-shell-mousewheel-zoom-git')
+provides=('gnome-shell-mousewheel-zoom')
+install=gnome-shell-mousewheel-zoom.install
+source=("gnome-shell-mousewheel-zoom_$pkgver.tar.gz::https://github.com/tobiasquinn/gnome-shell-mousewheel-zoom/tarball/upstream/$pkgver")
+md5sums=('6fd73ac036c8e6d2a499d28df52fdcb5')
+_sourcename=('tobiasquinn-gnome-shell-mousewheel-zoom-16d8078')
+build() {
+ cd "$srcdir/${_sourcename}"
+
+ make &> /dev/null
+}
+
+package() {
+ install -D -m755 ${srcdir}/${_sourcename}/mousewheelzoom "${pkgdir}/usr/bin/mousewheelzoom" || return 1
+ install -D -m644 ${srcdir}/${_sourcename}/mousewheelzoom.desktop "${pkgdir}/etc/xdg/autostart/mousewheelzoom.desktop" || return 1
+ install -D -m644 ${srcdir}/${_sourcename}/com.tobiasquinn.mousewheelzoom.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/com.tobiasquinn.mousewheelzoom.gschema.xml" || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-mousewheel-zoom.install b/gnome-shell-mousewheel-zoom.install
new file mode 100644
index 000000000000..6389e5eb0883
--- /dev/null
+++ b/gnome-shell-mousewheel-zoom.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ post_install $1
+}
+
+post_upgrade() {
+ post_install $1
+}