summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Bryskin2023-08-18 14:58:28 +0300
committerNikolay Bryskin2023-08-18 14:58:28 +0300
commitcb59aba2a655cfd7ef18acc065af50e64494deb8 (patch)
tree4fc1516f544d21e330b51d6f0a97a8020ba0eae2
parent3e68dd6394701064e1273dddc724ee363b7652d1 (diff)
downloadaur-cb59aba2a655cfd7ef18acc065af50e64494deb8.tar.gz
Update to Gnome 44
-rw-r--r--0001-main-Leak-the-GJS-context-and-ShellGlobal.patch28
-rw-r--r--PKGBUILD100
2 files changed, 98 insertions, 30 deletions
diff --git a/0001-main-Leak-the-GJS-context-and-ShellGlobal.patch b/0001-main-Leak-the-GJS-context-and-ShellGlobal.patch
new file mode 100644
index 000000000000..1e4188749f0b
--- /dev/null
+++ b/0001-main-Leak-the-GJS-context-and-ShellGlobal.patch
@@ -0,0 +1,28 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
+Date: Wed, 6 Oct 2021 10:00:43 +0200
+Subject: [PATCH] main: Leak the GJS context and ShellGlobal
+
+There are many crash-on-exit happening as a side effect of destroying
+the GJS context. Work around these until we have a better solution by
+leaking them.
+---
+ src/main.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/main.c b/src/main.c
+index 29275cda0725..2311a74bd110 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -589,9 +589,11 @@ main (int argc, char **argv)
+
+ shell_profiler_shutdown ();
+
++#if 0
+ g_debug ("Doing final cleanup");
+ _shell_global_destroy_gjs_context (shell_global_get ());
+ g_object_unref (shell_global_get ());
++#endif
+
+ return ecode;
+ }
diff --git a/PKGBUILD b/PKGBUILD
index 4205bd84fd9e..ee021143c3aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,45 +4,81 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-screencast-vaapi
-pkgver=43.1
-pkgrel=1
+_pkgname=gnome-shell
+pkgver=44.1
+pkgrel=3
epoch=1
-pkgdesc="Next generation desktop shell (screencast records with VAAPI)"
+pkgdesc="Next generation desktop shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
license=(GPL)
-depends=(accountsservice gcr-4 gjs upower gnome-session gtk4
- gnome-settings-daemon gsettings-desktop-schemas libcanberra-pulse
- libgdm libsecret mutter libnma unzip libibus gnome-autoar
- gnome-disk-utility libsoup3 libgweather-4 gst-plugins-base-libs)
-makedepends=(gtk-doc gnome-control-center evolution-data-server
- gobject-introspection git 'meson>=0.64' sassc asciidoc bash-completion)
-checkdepends=(xorg-server-xvfb)
-optdepends=('gnome-control-center: System settings'
- 'evolution-data-server: Evolution calendar integration'
- 'gst-plugins-good: Screen recording'
- 'gst-plugin-pipewire: Screen recording'
- 'gnome-bluetooth-3.0: Bluetooth support'
- 'power-profiles-daemon: Power profile switching')
+depends=(
+ accountsservice
+ gcr-4
+ gjs
+ gnome-autoar
+ gnome-session
+ gnome-settings-daemon
+ gsettings-desktop-schemas
+ gtk4
+ libadwaita
+ libcanberra-pulse
+ libgdm
+ libgweather-4
+ libibus
+ libnma-gtk4
+ libsecret
+ libsoup3
+ mutter
+ unzip
+ upower
+)
+makedepends=(
+ asciidoc
+ bash-completion
+ evolution-data-server
+ git
+ gnome-control-center
+ gobject-introspection
+ gtk-doc
+ meson
+ sassc
+)
+checkdepends=(
+ appstream-glib
+ python-dbusmock
+ xorg-server-xvfb
+)
+optdepends=(
+ 'evolution-data-server: Evolution calendar integration'
+ 'gnome-bluetooth-3.0: Bluetooth support'
+ 'gnome-control-center: System settings'
+ 'gnome-disk-utility: Mount with keyfiles'
+ 'gst-plugin-pipewire: Screen recording'
+ 'gst-plugins-good: Screen recording'
+ 'power-profiles-daemon: Power profile switching'
+ 'switcheroo-control: Multi-GPU support'
+)
conflicts=(gnome-shell gnome-shell-debug)
provides=(gnome-shell)
groups=(gnome)
-options=(debug)
-_commit=8b00255cc31814b09a35c9be38228d873676233e # tags/43.1^0
-source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- screencast-vaapi.patch)
-sha256sums=('SKIP'
- 'SKIP'
- 'c52281a39041cfd961b7347f6e4a76244e294fe2f8a442df1aaf8453e91149ea')
+_commit=b0ca64e7775225b7c5d049571a44ef40bf516406 # tags/44.1^0
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "screencast-vaapi.patch"
+)
+b2sums=('SKIP'
+ 'SKIP'
+ 'bb2bba3fe590fddeca09d34df89871b0ba41f443e0c7ba22091f1a4b41eb80fd3e8d77b75d9e6dfa2e062e27f20741be2448e58447a30940fbb1ab6ea2e26ad2')
pkgver() {
- cd gnome-shell
+ cd $_pkgname
git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
- cd gnome-shell
+ cd $_pkgname
patch -p1 < ../../screencast-vaapi.patch
git submodule init
@@ -51,18 +87,22 @@ prepare() {
}
build() {
+ local meson_options=(
+ -D gtk_doc=true
+ )
+
CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
LDFLAGS+=" -Wl,-Bsymbolic-functions"
- arch-meson gnome-shell build -D gtk_doc=true
+ arch-meson $_pkgname build "${meson_options[@]}"
meson compile -C build
}
_check() (
- export XDG_RUNTIME_DIR="$PWD/runtime-dir"
+ export XDG_RUNTIME_DIR="$PWD/rdir"
mkdir -p -m 700 "$XDG_RUNTIME_DIR"
- meson test -C build --print-errorlogs
+ meson test -C build --print-errorlogs -t 3
)
check() {
@@ -71,7 +111,7 @@ check() {
}
package() {
- depends+=(libmutter-11.so)
+ depends+=(libmutter-12.so)
meson install -C build --destdir "$pkgdir"
}