summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Bryskin2023-10-13 13:43:46 +0300
committerNikolay Bryskin2023-10-13 13:43:46 +0300
commited17ca33142ffd0d7d5d737b7318e493d44a76e3 (patch)
tree10ad04933812f16aab8d30553966fed5df11d59f
parentcbaefb025a3d8c082c1b2143f466477ee0ca7f88 (diff)
downloadaur-ed17ca33142ffd0d7d5d737b7318e493d44a76e3.tar.gz
Update to gnome-shell 45.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c59da2bef17..ff28d91fe36b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-screencast-vaapi
pkgdesc = Next generation desktop shell
- pkgver = 44.1
- pkgrel = 3
+ pkgver = 45.0
+ pkgrel = 1
epoch = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
@@ -45,11 +45,12 @@ pkgbase = gnome-shell-screencast-vaapi
optdepends = gst-plugin-pipewire: Screen recording
optdepends = gst-plugins-good: Screen recording
optdepends = power-profiles-daemon: Power profile switching
+ optdepends = python-gobject: gnome-shell-test-tool performance tester
optdepends = switcheroo-control: Multi-GPU support
provides = gnome-shell
conflicts = gnome-shell
conflicts = gnome-shell-debug
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=b0ca64e7775225b7c5d049571a44ef40bf516406
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=2127c62b210f605747e019e6e2abee82516e3ccb
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
source = screencast-vaapi.patch
b2sums = SKIP
@@ -76,4 +77,4 @@ pkgname = gnome-shell-screencast-vaapi
depends = mutter
depends = unzip
depends = upower
- depends = libmutter-12.so
+ depends = libmutter-13.so
diff --git a/PKGBUILD b/PKGBUILD
index ee021143c3aa..73dee208644a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Nikolay Bryskin <nbryskin@gmail.com>
+# Contributor: Fabian Bornschein <fabiscafe-at-mailbox-dot-org>
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-screencast-vaapi
_pkgname=gnome-shell
-pkgver=44.1
-pkgrel=3
+pkgver=45.0
+pkgrel=1
epoch=1
pkgdesc="Next generation desktop shell"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -57,12 +58,13 @@ optdepends=(
'gst-plugin-pipewire: Screen recording'
'gst-plugins-good: Screen recording'
'power-profiles-daemon: Power profile switching'
+ 'python-gobject: gnome-shell-test-tool performance tester'
'switcheroo-control: Multi-GPU support'
)
conflicts=(gnome-shell gnome-shell-debug)
provides=(gnome-shell)
groups=(gnome)
-_commit=b0ca64e7775225b7c5d049571a44ef40bf516406 # tags/44.1^0
+_commit=2127c62b210f605747e019e6e2abee82516e3ccb # tags/45.0^0
source=(
"git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
@@ -80,7 +82,7 @@ pkgver() {
prepare() {
cd $_pkgname
- patch -p1 < ../../screencast-vaapi.patch
+ patch -p1 < $srcdir/screencast-vaapi.patch
git submodule init
git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
git -c protocol.file.allow=always submodule update
@@ -102,6 +104,8 @@ _check() (
export XDG_RUNTIME_DIR="$PWD/rdir"
mkdir -p -m 700 "$XDG_RUNTIME_DIR"
+ export NO_AT_BRIDGE=1 GTK_A11Y=none
+
meson test -C build --print-errorlogs -t 3
)
@@ -111,7 +115,7 @@ check() {
}
package() {
- depends+=(libmutter-12.so)
+ depends+=(libmutter-13.so)
meson install -C build --destdir "$pkgdir"
}