summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2015-05-23 14:09:12 +0200
committerGordian Edenhofer2015-05-23 14:09:12 +0200
commit1267f26acec1b7348231f18911580fc9da9665e3 (patch)
tree9f92cc935bcebfc428164ad66e5d6b69aaebeeca
downloadaur-1267f26acec1b7348231f18911580fc9da9665e3.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
-rw-r--r--elegance-colors.install14
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99c4726d554c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.1
+# Sat May 23 12:03:45 UTC 2015
+pkgbase = gnome-shell-theme-elegance-colors-git
+ pkgdesc = A chameleon theme for Gnome Shell which can change colors according to the current GTK theme, current wallpaper (uses imagemagick to get color) or a user defined color.
+ pkgver = 238.ca44e2f
+ pkgrel = 3
+ url = https://github.com/satya164/elegance-colors
+ install = elegance-colors.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ depends = gtk3
+ depends = gnome-shell>=3.6
+ depends = glib2
+ depends = imagemagick
+ provides = gnome-shell-themes-elegance-colors
+ conflicts = gnome-shell-themes-elegance-colors
+ source = elegance-colors::git+https://github.com/satya164/elegance-colors.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-theme-elegance-colors-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5810ef79b7db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+# Submitter: L <alaviss0@gmail.com>
+
+pkgname=gnome-shell-theme-elegance-colors-git
+_pkgname=elegance-colors
+pkgver=238.ca44e2f
+pkgrel=3
+pkgdesc="A chameleon theme for Gnome Shell which can change colors according to the current GTK theme, current wallpaper (uses imagemagick to get color) or a user defined color."
+arch=('i686' 'x86_64')
+url="https://github.com/satya164/elegance-colors"
+license=('GPL3')
+depends=('gtk3' 'gnome-shell>=3.6' 'glib2' 'imagemagick')
+makedepends=('vala')
+conflicts=('gnome-shell-themes-elegance-colors')
+provides=('gnome-shell-themes-elegance-colors')
+install="${_pkgname}.install"
+source=(${_pkgname}::'git+https://github.com/satya164/elegance-colors.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+
+build() {
+ make -C "${srcdir}/${_pkgname}"
+}
+
+package() {
+ make -C "${srcdir}/${_pkgname}" DESTDIR="${pkgdir}" install
+}
diff --git a/elegance-colors.install b/elegance-colors.install
new file mode 100644
index 000000000000..461001117051
--- /dev/null
+++ b/elegance-colors.install
@@ -0,0 +1,14 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor
+
+ echo -e "\e[34;1m==>\e[39;1m NOTE: Start the elegance-colors daemon process prior to configuring a theme. \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m Do so by running "elegance-colors" in a terminal. \e[0m"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor
+}