summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortbepdb2018-05-28 18:10:47 +0600
committertbepdb2018-05-28 18:10:47 +0600
commit29c1cb03679b86bddf94b158c7afb259f2ac8f2b (patch)
tree13a8301713160bfe0b728033833f388ee14ef932
downloadaur-29c1cb03679b86bddf94b158c7afb259f2ac8f2b.tar.gz
Initial import
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD59
-rw-r--r--tweener-fix.patch14
3 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f4bd65064af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+# Generated by mksrcinfo v8
+# Mon May 28 12:08:25 UTC 2018
+pkgbase = gnome-shell-tweener-fix
+ pkgdesc = The next generation GNOME Shell
+ pkgver = 3.28.2
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/GnomeShell
+ arch = x86_64
+ groups = gnome
+ license = GPL2
+ makedepends = gtk-doc
+ makedepends = gnome-control-center
+ makedepends = evolution-data-server
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ makedepends = sassc
+ depends = accountsservice
+ depends = gcr
+ depends = gjs
+ depends = gnome-bluetooth
+ depends = upower
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gnome-themes-extra
+ depends = gsettings-desktop-schemas
+ depends = libcanberra-pulse
+ depends = libcroco
+ depends = libgdm
+ depends = libsecret
+ depends = mutter
+ depends = nm-connection-editor
+ depends = unzip
+ depends = gstreamer
+ depends = libibus
+ optdepends = gnome-control-center: System settings
+ optdepends = evolution-data-server: Evolution calendar integration
+ provides = gnome-shell
+ conflicts = gnome-shell
+ source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=c70b18764b2658849b170c897ce4c423a118d7f2
+ source = git+https://git.gnome.org/browse/libgnome-volume-control
+ source = tweener-fix.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gnome-shell-tweener-fix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e8b310d81cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id$
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Flamelab <panosfilip@gmail.com
+
+pkgname=gnome-shell-tweener-fix
+pkgver=3.28.2
+pkgrel=1
+pkgdesc="The next generation GNOME Shell"
+url="https://wiki.gnome.org/Projects/GnomeShell"
+arch=(x86_64)
+license=(GPL2)
+real_pkgname=gnome-shell
+provides=(${real_pkgname}=${pkgver})
+
+depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
+ gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
+ mutter nm-connection-editor unzip gstreamer libibus)
+makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
+ sassc)
+optdepends=('gnome-control-center: System settings'
+ 'evolution-data-server: Evolution calendar integration')
+groups=(gnome)
+_commit=c70b18764b2658849b170c897ce4c423a118d7f2 # tags/3.28.2^0
+source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
+ "git+https://git.gnome.org/browse/libgnome-volume-control"
+ "tweener-fix.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+conflicts=(${real_pkgname})
+provides=(${real_pkgname})
+
+pkgver() {
+ cd $real_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $real_pkgname
+
+ # Move the plugin to our custom epiphany-only dir
+ sed -i "s/'mozilla'/'epiphany'/g" meson.build
+ patch -Np1 -i ../tweener-fix.patch
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
+}
+
+build() {
+ arch-meson $real_pkgname build -D gtk_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ # Must exist; FS#37412
+ mkdir "$pkgdir/usr/share/gnome-shell/modes"
+}
diff --git a/tweener-fix.patch b/tweener-fix.patch
new file mode 100644
index 000000000000..2a6288f49598
--- /dev/null
+++ b/tweener-fix.patch
@@ -0,0 +1,14 @@
+diff --git a/js/ui/tweener.js b/js/ui/tweener.js
+index 1a85e2fb1..8e8d90a8e 100644
+--- a/js/ui/tweener.js
++++ b/js/ui/tweener.js
+@@ -88,8 +88,8 @@ function _addHandler(target, params, name, handler) {
+ let eventScope = oldScope ? oldScope : target;
+
+ params[name] = () => {
+- oldHandler.apply(eventScope, oldParams);
+ handler(target);
++ oldHandler.apply(eventScope, oldParams);
+ };
+ } else
+ params[name] = () => { handler(target); };