summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2019-07-30 17:36:02 +0200
committerLubosz Sarnecki2019-07-30 17:36:02 +0200
commit47111fd61bd4e84b77c9fcda1a7769cbc6068494 (patch)
tree0d4f65fec3d442989ede79a35505ed83988d7135
downloadaur-47111fd61bd4e84b77c9fcda1a7769cbc6068494.tar.gz
Initial commit.
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD58
2 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd465d4e8068
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+# Generated by mksrcinfo v8
+# Tue Jul 30 15:35:45 UTC 2019
+pkgbase = gnome-shell-xrdesktop-git
+ pkgdesc = The next generation GNOME Shell - with patches for xrdesktop.
+ pkgver = 3.32.2
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xrdesktop
+ arch = x86_64
+ groups = gnome
+ license = GPL2
+ makedepends = gtk-doc
+ makedepends = gnome-control-center
+ makedepends = evolution-data-server
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = meson
+ makedepends = sassc
+ depends = accountsservice
+ depends = gcr
+ depends = gjs
+ depends = gnome-bluetooth
+ depends = upower
+ depends = gnome-session
+ depends = gnome-settings-daemon
+ depends = gnome-themes-extra
+ depends = gsettings-desktop-schemas
+ depends = libcanberra-pulse
+ depends = libcroco
+ depends = libgdm
+ depends = libsecret
+ depends = mutter
+ depends = nm-connection-editor
+ depends = unzip
+ depends = gstreamer
+ depends = libibus
+ depends = xrdesktop-git
+ depends = libinputsynth-git
+ optdepends = gnome-control-center: System settings
+ optdepends = evolution-data-server: Evolution calendar integration
+ provides = gnome-shell=3.32.2
+ conflicts = gnome-shell
+ replaces = gnome-shell
+ options = debug
+ options = !strip
+ source = gnome-shell::git+https://gitlab.freedesktop.org/xrdesktop/gnome-shell.git#branch=3.32.2-xrdesktop
+ source = git+https://git.gnome.org/browse/libgnome-volume-control
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = gnome-shell-xrdesktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df98fa17fa3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# $Id$
+# Maintainer: Lubosz Sarnecki <lubosz.sarnecki@collabora.com>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Flamelab <panosfilip@gmail.com
+
+basename=gnome-shell
+pkgname=$basename-xrdesktop-git
+pkgver=3.32.2
+pkgrel=1
+replaces=($basename)
+conflicts=($basename)
+pkgdesc="The next generation GNOME Shell - with patches for xrdesktop."
+url="https://gitlab.freedesktop.org/xrdesktop"
+arch=(x86_64)
+license=(GPL2)
+depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gnome-settings-daemon
+ gnome-themes-extra gsettings-desktop-schemas libcanberra-pulse libcroco libgdm libsecret
+ mutter nm-connection-editor unzip gstreamer libibus xrdesktop-git libinputsynth-git)
+makedepends=(gtk-doc gnome-control-center evolution-data-server gobject-introspection git meson
+ sassc)
+optdepends=('gnome-control-center: System settings'
+ 'evolution-data-server: Evolution calendar integration')
+groups=(gnome)
+provides=(gnome-shell=$pkgver)
+source=($basename::"git+https://gitlab.freedesktop.org/xrdesktop/gnome-shell.git#branch=3.32.2-xrdesktop"
+ "git+https://git.gnome.org/browse/libgnome-volume-control")
+
+sha256sums=('SKIP'
+ 'SKIP')
+options=('debug' '!strip')
+
+pkgver() {
+ cd $basename
+ grep -Po "(?<=^ version: ')((\d+\.)+\d+)" meson.build
+}
+
+prepare() {
+ cd $basename
+
+ # Move the plugin to our custom epiphany-only dir
+ sed -i "s/'mozilla'/'epiphany'/g" meson.build
+
+ git submodule init
+ git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
+ git submodule update
+}
+
+build() {
+ arch-meson $basename build -D gtk_doc=true --buildtype=debug
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ # Must exist; FS#37412
+ mkdir "$pkgdir/usr/share/gnome-shell/modes"
+}