summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Démoulins2015-07-02 11:35:53 +0200
committerClément Démoulins2015-07-02 11:35:53 +0200
commit8dd453efa094d0317a9ea75000833e23aebaa3cf (patch)
tree7df284075cf481bc70c0ed19710e943bb08adc6e
downloadaur-8dd453efa094d0317a9ea75000833e23aebaa3cf.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--gnome-ssh-askpass2.sh10
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0714a5d5b8cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnome-ssh-askpass2
+ pkgdesc = A GNOME and Gtk2 passphrase requesters for ssh-add.
+ pkgver = 6.2p2
+ pkgrel = 3
+ url = http://www.openssh.org/portable.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ provides = x11-ssh-askpass
+ conflicts = x11-ssh-askpass
+ conflicts = ssh-askpass-fullscreen
+ conflicts = gnome-ssh-askpass
+ source = ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-6.2p2.tar.gz
+ source = gnome-ssh-askpass2.sh
+ md5sums = be46174dcbb77ebb4ea88ef140685de1
+ md5sums = 2eb5571a9751c94c90760bf3c05bd095
+
+pkgname = gnome-ssh-askpass2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..739e9859e7a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Clément DÉMOULINS <clement@archivel.fr>
+
+pkgname=gnome-ssh-askpass2
+_pkgname=openssh
+pkgver=6.2p2
+pkgrel=3
+pkgdesc='A GNOME and Gtk2 passphrase requesters for ssh-add.'
+arch=(i686 x86_64)
+url="http://www.openssh.org/portable.html"
+license=('custom')
+depends=('gtk2')
+provides=('x11-ssh-askpass')
+conflicts=('x11-ssh-askpass' 'ssh-askpass-fullscreen' 'gnome-ssh-askpass')
+
+source=(ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/$_pkgname-$pkgver.tar.gz
+ gnome-ssh-askpass2.sh)
+md5sums=('be46174dcbb77ebb4ea88ef140685de1'
+ '2eb5571a9751c94c90760bf3c05bd095')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver/contrib"
+
+ make gnome-ssh-askpass2
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver/contrib"
+
+ install -D -m755 gnome-ssh-askpass2 "$pkgdir/usr/lib/ssh/$pkgname"
+ install -d "$pkgdir/etc/profile.d"
+ install -Dm755 "$srcdir/gnome-ssh-askpass2.sh" "$pkgdir/etc/profile.d/"
+ install -Dm644 "$srcdir/$_pkgname-$pkgver/LICENCE" "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+}
diff --git a/gnome-ssh-askpass2.sh b/gnome-ssh-askpass2.sh
new file mode 100644
index 000000000000..be78a0b2260f
--- /dev/null
+++ b/gnome-ssh-askpass2.sh
@@ -0,0 +1,10 @@
+#
+# /etc/profile.d/gnome-ssh-askpass2
+#
+
+if [ -f "/usr/lib/ssh/gnome-ssh-askpass2" ] ; then
+ SSH_ASKPASS="/usr/lib/ssh/gnome-ssh-askpass2"
+ export SSH_ASKPASS
+fi
+
+# /etc/profile.d/gnome-ssh-askpass2 ends here.