summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-01-14 21:06:17 +0100
committerPhilip Goto2019-01-14 21:09:56 +0100
commit454f15be1765b2695f0504397c4923722b969cb7 (patch)
tree44b1bb5d5ad2e60d9bc21592c5592ae2e0b34285
downloadaur-454f15be1765b2695f0504397c4923722b969cb7.tar.gz
Initialize package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..833f83e8b80e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnome-system-monitor-git
+ pkgdesc = View current processes and monitor system state
+ pkgver = 3.31.3.r5.g56ebc51b
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/SystemMonitor
+ arch = x86_64
+ license = GPL
+ makedepends = meson
+ makedepends = yelp-tools
+ makedepends = git
+ depends = libgtop
+ depends = gtkmm3
+ depends = librsvg
+ depends = systemd
+ provides = gnome-system-monitor
+ conflicts = gnome-system-monitor
+ source = git+https://gitlab.gnome.org/GNOME/gnome-system-monitor.git
+ sha256sums = SKIP
+
+pkgname = gnome-system-monitor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e51b3c29bd5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=gnome-system-monitor-git
+pkgver=3.31.3.r5.g56ebc51b
+pkgrel=1
+pkgdesc="View current processes and monitor system state"
+url="https://wiki.gnome.org/Apps/SystemMonitor"
+arch=(x86_64)
+license=(GPL)
+depends=(libgtop gtkmm3 librsvg systemd)
+makedepends=(meson yelp-tools git)
+provides=(gnome-system-monitor)
+conflicts=(gnome-system-monitor)
+source=("git+https://gitlab.gnome.org/GNOME/gnome-system-monitor.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gnome-system-monitor
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson gnome-system-monitor build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}