summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Edson2021-11-15 11:56:39 -0800
committerJason Edson2021-11-15 11:56:39 -0800
commit28559cff45fe7aeab8b150cfb85017b19b59e147 (patch)
treeee6cf698ab465645824e1bfe5b468848230ef4ff
parent20d92f0a8de20df579548ab44301054f773dcde1 (diff)
downloadaur-28559cff45fe7aeab8b150cfb85017b19b59e147.tar.gz
Clean up PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdb5a076b21f..e6911a71be35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-terminal-fedora
pkgdesc = The GNOME Terminal Emulator with Fedora patches
pkgver = 3.42.1
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Terminal
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c3b0640dd648..b1651730b10a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
_pkgname='gnome-terminal'
pkgname="${_pkgname}-fedora"
pkgver=3.42.1
-pkgrel=1
+pkgrel=2
pkgdesc='The GNOME Terminal Emulator with Fedora patches'
-arch=('i686'
- 'x86_64')
url='https://wiki.gnome.org/Apps/Terminal'
license=('GPL')
+arch=('i686'
+ 'x86_64')
depends=('vte3-notification>=0.66.0'
'gsettings-desktop-schemas')
makedepends=('git'
@@ -35,8 +35,7 @@ _fcommit='6ce4c343f37e66397e42a4c1bfded7e083fd1bea'
_fpatchfile100='gnome-terminal-cntr-ntfy-autottl-ts.patch'
_fgsoverridefile='org.gnome.Terminal.gschema.override'
-source=(
- "https://download.gnome.org/sources/${_pkgname}/${pkgver::4}/${_pkgname}-${pkgver}.tar.xz"
+source=("https://download.gnome.org/sources/${_pkgname}/${pkgver::4}/${_pkgname}-${pkgver}.tar.xz"
"${_fpatchfile100}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile100}"
"${_fgsoverridefile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fgsoverridefile}"
)
@@ -47,11 +46,12 @@ sha256sums=('c319b1405501b8c7693e616f48eced41695d2e786148ca5f9e27bc7d98f4aeb1'
prepare () {
cd "${_pkgname}-${pkgver}"
+ # Apply patches
patch -p1 -i "../${_fpatchfile100}-${_fcommit}"
}
build() {
- arch-meson gnome-terminal-${pkgver} build \
+ arch-meson build gnome-terminal-${pkgver} \
-D b_lto=false \
-D docs=true \
-Dnautilus_extension=true \
@@ -60,8 +60,8 @@ build() {
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
+ meson install -C build --destdir "$pkgdir"
- install -Dm644 "../${_fgsoverridefile}-${_fcommit}" \
+ install -Dm644 "$srcdir/${_fgsoverridefile}-${_fcommit}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${_fgsoverridefile}"
}