summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2021-04-15 11:48:34 +0200
committerPhilip Goto2021-04-15 11:48:34 +0200
commit1ebd8178bda89e9fecdecd92f654c1ddd01f2d77 (patch)
tree5daffab10bae2cf542725d4c899161341b74e9c3
downloadaur-1ebd8178bda89e9fecdecd92f654c1ddd01f2d77.tar.gz
Initialize
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e813d40633a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-text-editor
+ pkgdesc = Simple text editor that focuses on session management
+ pkgver = 3.39.92
+ pkgrel = 1
+ url = https://gitlab.gnome.org/chergert/gnome-text-editor
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ depends = gtksourceview5
+ depends = libadwaita
+ source = https://gitlab.gnome.org/chergert/gnome-text-editor/-/archive/3.39.92/gnome-text-editor-3.39.92.tar.gz
+ sha256sums = d36adbf0e2c6d74380986d64aaaa8ad0aa39ffabb304648a94acfa0b2f9771b4
+
+pkgname = gnome-text-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2429efe2725c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=gnome-text-editor
+pkgver=3.39.92
+pkgrel=1
+pkgdesc="Simple text editor that focuses on session management"
+url="https://gitlab.gnome.org/chergert/gnome-text-editor"
+license=("GPL3")
+arch=(i686 x86_64 armv7h aarch64)
+depends=(gtksourceview5 libadwaita)
+makedepends=(meson)
+source=("${url}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('d36adbf0e2c6d74380986d64aaaa8ad0aa39ffabb304648a94acfa0b2f9771b4')
+
+build() {
+ arch-meson ${pkgname}-${pkgver} build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+
+ rm -rf "${pkgdir}/usr/share/gtksourceview-5"
+}