summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIppytraxx2015-09-12 13:54:32 +0200
committerIppytraxx2015-09-12 13:54:32 +0200
commitf15aedccb01da88a2500927b57967d424dacc8b9 (patch)
treea819311bad5a75db8dee9a6350f13b47e05e30fc
downloadaur-f15aedccb01da88a2500927b57967d424dacc8b9.tar.gz
Init
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD35
-rw-r--r--gnome-twitch-git.install16
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ff1d02c7c8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = gnome-twitch-git
+ pkgdesc = Enjoy Twitch on your GNOME desktop
+ pkgver = r20.832f159
+ pkgrel = 1
+ url = https://github.com/Ippytraxx/gnome-twitch
+ install = gnome-twitch-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = libsoup
+ depends = json-glib
+ depends = gstreamer
+ depends = gst-libav
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-ugly
+ source = gnome-twitch-git::git+https://github.com/ippytraxx/gnome-twitch.git
+ md5sums = SKIP
+
+pkgname = gnome-twitch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..745b033863a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Vincent <ippytraxx@installgentoo.com>
+
+pkgname=gnome-twitch-git
+pkgver=r20.832f159
+pkgrel=1
+pkgdesc="Enjoy Twitch on your GNOME desktop"
+arch=('i686' 'x86_64')
+url="https://github.com/Ippytraxx/gnome-twitch"
+license=('GPL3')
+makedepends=('git' 'meson')
+depends=('gtk3' 'libsoup' 'json-glib' 'gstreamer' 'gst-libav' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-ugly')
+install=gnome-twitch-git.install
+source=("$pkgname::git+https://github.com/ippytraxx/gnome-twitch.git")
+md5sums=('SKIP')
+
+pkgver()
+{
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "$pkgname"
+ mkdir build
+ meson . build
+ cd build
+ ninja
+}
+
+package()
+{
+ cd "$pkgname"/build
+ mesonconf -Dprefix=/usr
+ DESTDIR="$pkgdir" ninja install
+}
diff --git a/gnome-twitch-git.install b/gnome-twitch-git.install
new file mode 100644
index 000000000000..c0c2237a5c22
--- /dev/null
+++ b/gnome-twitch-git.install
@@ -0,0 +1,16 @@
+post_install()
+{
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ post_install
+}