summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Rauter2018-02-15 14:00:59 +0100
committerGabriel Rauter2018-02-15 14:00:59 +0100
commit48fdcd915a5532351225be02b26629c3446e9136 (patch)
tree6d74dcbbc4d823c3b7b5880a7a78d99794ab7beb
downloadaur-48fdcd915a5532351225be02b26629c3446e9136.tar.gz
add gnome-usage
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15a37e666c45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gnome-usage
+ pkgdesc = A nice way to view information about use of system resources
+ pkgver = v3.27.90+2+g3908ab6
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Usage
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL3
+ makedepends = git
+ makedepends = vala
+ makedepends = gobject-introspection
+ makedepends = meson
+ depends = gtk3
+ depends = libgtop
+ depends = accountsservice
+ provides = gnome-usage
+ conflicts = gnome-usage
+ source = git+https://gitlab.gnome.org/GNOME/gnome-usage.git#tag=
+ sha256sums = SKIP
+
+pkgname = gnome-usage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cca9cc26623
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriel Rauter <rauter.gabriel@gmail.com>
+
+pkgname=gnome-usage
+pkgver=v3.27.90+2+g3908ab6
+pkgrel=1
+pkgdesc="A nice way to view information about use of system resources"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://wiki.gnome.org/Apps/Usage"
+license=('GPL3')
+depends=('gtk3' 'libgtop' 'accountsservice')
+makedepends=('git' 'vala' 'gobject-introspection' 'meson')
+provides=("$pkgname")
+conflicts=("$pkgname")
+_tag=v3.27.90
+source=("git+https://gitlab.gnome.org/GNOME/$pkgname.git#tag=$tag")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ rm -rf build
+ arch-meson "$pkgname" build
+ ninja -v -C build
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja -C build install
+}
+
+# vim:set ts=2 sw=2 et: