summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-02-22 18:50:12 +0100
committerKevin Majewski2020-02-22 18:50:12 +0100
commit630bfef1c43f5cfa2a445dc30007345cb87d0aa1 (patch)
tree0c623c6a3028cff412c164f9f258b2187d61557c
downloadaur-630bfef1c43f5cfa2a445dc30007345cb87d0aa1.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fa9f62fff45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = gnome-weather-git
+ pkgdesc = Access current weather conditions and forecasts
+ pkgver = 3.34.0+27+g07c3cf5
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Weather
+ arch = any
+ groups = gnome
+ license = GPL
+ makedepends = gobject-introspection
+ makedepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ depends = gtk3
+ depends = gjs
+ depends = libgweather
+ depends = geoclue2
+ depends = gnome-desktop
+ provides = gnome-weather
+ conflicts = gnome-weather
+ source = git+https://gitlab.gnome.org/GNOME/gnome-weather.git
+ sha512sums = SKIP
+
+pkgname = gnome-weather-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e9f1665afb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=gnome-weather-git
+_pkgname=gnome-weather
+pkgver=3.34.0+27+g07c3cf5
+pkgrel=1
+pkgdesc="Access current weather conditions and forecasts"
+url="https://wiki.gnome.org/Apps/Weather"
+arch=(any)
+license=(GPL)
+depends=('gtk3' 'gjs' 'libgweather' 'geoclue2' 'gnome-desktop')
+makedepends=('gobject-introspection' 'appstream-glib' 'git' 'meson')
+provides=('gnome-weather')
+conflicts=('gnome-weather')
+groups=('gnome')
+source=("git+https://gitlab.gnome.org/GNOME/gnome-weather.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}