summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-11-07 19:11:20 -0700
committerAinola2018-11-07 19:11:20 -0700
commit7fd6a0018a8ba47f89f9d91c1a09beb684c33f72 (patch)
treead74118c60093052fa39298c168d788c4be0b644
parentfa10e0165fd364ad008114fa14e7a2c30a122e67 (diff)
downloadaur-gnome-xcf-thumbnailer.tar.gz
slightly desuck this pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4c43a3eb1f7..e64fcf0a8735 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Sep 2 18:00:25 UTC 2018
pkgbase = gnome-xcf-thumbnailer
pkgdesc = GNOME thumbnailer for GIMP XCF files.
pkgver = 1.0
- pkgrel = 9
+ pkgrel = 10
url = https://download.gnome.org/sources/gnome-xcf-thumbnailer/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index c82058989804..534547147bf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,12 @@
pkgname=gnome-xcf-thumbnailer
pkgver=1.0
-pkgrel=9
+pkgrel=10
pkgdesc="GNOME thumbnailer for GIMP XCF files."
arch=('x86_64')
url="https://download.gnome.org/sources/gnome-xcf-thumbnailer/"
license=('GPL2')
-# Without gimp, .xcf thumbnails are never displayed
-depends=('glib2' 'libpng' 'gimp')
+depends=('glib2' 'libpng')
makedepends=('gconf')
source=("https://download.gnome.org/sources/gnome-xcf-thumbnailer/${pkgver}/gnome-xcf-thumbnailer-${pkgver}.tar.bz2"
"gnome-xcf-thumbnailer.thumbnailer"
@@ -30,15 +29,11 @@ prepare(){
# libpng12 does not distribute headers any more. We must adjust to be
# buildable with recent versions of libpng.
patch -d gnome-xcf-thumbnailer-$pkgver -p1 < NULL-updates.patch
-
- install -m755 -d "$pkgdir/usr/share/gconf/schemas"
- gconf-merge-schema "$pkgdir/usr/share/gconf/schemas/${pkgname}.schemas" \
- --domain gnome-xcf-thumbnailer "$pkgdir/usr/share/$pkgname/${pkgname}.sc"
}
build() {
cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sysconfdir=/etc
make
}
@@ -48,4 +43,7 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 ../gnome-xcf-thumbnailer.thumbnailer -t "$pkgdir/usr/share/thumbnailers/"
+ install -m755 -d "$pkgdir/usr/share/gconf/schemas"
+ gconf-merge-schema "$pkgdir/usr/share/gconf/schemas/${pkgname}.schemas" \
+ --domain gnome-xcf-thumbnailer "$pkgdir/usr/share/$pkgname/${pkgname}.sc"
}