summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 10:56:52 +1000
committerPhillip Smith2015-06-02 10:56:52 +1000
commite446cb61338ef13e1e9c616bdb02739efd7bf250 (patch)
tree5a1e0c1dc3a27d8d9c1ab406dce525b62bbc5c3b
downloadaur-e446cb61338ef13e1e9c616bdb02739efd7bf250.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD67
-rw-r--r--gnomebaker-0.6.4-ldadd.patch11
-rw-r--r--gnomebaker-0.6.4-libnotify-0.7.patch18
-rw-r--r--gnomebaker.install24
5 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e10f14cbb9f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gnomebaker
+ pkgdesc = A full featured CD/DVD burning application for Gnome
+ pkgver = 0.6.4
+ pkgrel = 4
+ url = http://gnomebaker.sourceforge.net
+ install = gnomebaker.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = perl-xml-parser
+ makedepends = rarian
+ makedepends = patch
+ depends = libgnomeui
+ depends = dvd+rw-tools
+ depends = cdrkit
+ depends = cdrdao
+ depends = gstreamer0.10-base-plugins
+ depends = libnotify
+ source = http://downloads.sourceforge.net/gnomebaker/gnomebaker-0.6.4.tar.gz
+ source = gnomebaker-0.6.4-libnotify-0.7.patch
+ source = gnomebaker-0.6.4-ldadd.patch
+ md5sums = db43492684e0ba349be85e81ce0a9e56
+ md5sums = 137f6b576d0d49990ac5b9c34bc2fbc9
+ md5sums = 37a70793b2d708fed1dbc0416b91554e
+
+pkgname = gnomebaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbf684941980
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Gary Wright <wriggary@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Christopher Cox <nuopus@gmail.com>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=gnomebaker
+pkgver=0.6.4
+pkgrel=4
+pkgdesc="A full featured CD/DVD burning application for Gnome"
+license=('GPL')
+arch=('i686' 'x86_64')
+url="http://gnomebaker.sourceforge.net"
+install=gnomebaker.install
+depends=('libgnomeui' 'dvd+rw-tools' 'cdrkit' 'cdrdao' 'gstreamer0.10-base-plugins' 'libnotify')
+makedepends=('perl-xml-parser' 'rarian' 'patch')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'gnomebaker-0.6.4-libnotify-0.7.patch'
+ 'gnomebaker-0.6.4-ldadd.patch')
+md5sums=('db43492684e0ba349be85e81ce0a9e56'
+ '137f6b576d0d49990ac5b9c34bc2fbc9'
+ '37a70793b2d708fed1dbc0416b91554e')
+
+prepare() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+
+ patch -p0 < "$srcdir"/gnomebaker-0.6.4-libnotify-0.7.patch
+
+ # patch from fedora; thanks to hadrons123 for finding
+ patch -p1 < "$srcdir"/gnomebaker-0.6.4-ldadd.patch
+}
+
+build() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-libnotify
+
+ make LDFLAGS+="-Wl,--export-dynamic"
+}
+
+package() {
+ cd "$srcdir"/${pkgname}-${pkgver}
+
+ make GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 DESTDIR="$pkgdir" install
+
+ install -dm755 "$pkgdir"/usr/share/gconf/schemas
+ gconf-merge-schema \
+ "$pkgdir"/usr/share/gconf/schemas/${pkgname}.schemas \
+ "$pkgdir"/etc/gconf/schemas/*.schemas
+ rm -f "$pkgdir"/etc/gconf/schemas/*.schemas
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnomebaker-0.6.4-ldadd.patch b/gnomebaker-0.6.4-ldadd.patch
new file mode 100644
index 000000000000..f552f4abaa0f
--- /dev/null
+++ b/gnomebaker-0.6.4-ldadd.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -255,7 +255,7 @@ gnomebaker_SOURCES = \
+ cairofillbar.c cairofillbar.h \
+ backend.c backend.h
+
+-gnomebaker_LDADD = @GNOMEBAKER_LIBS@
++gnomebaker_LDADD = @GNOMEBAKER_LIBS@ -lm
+ gnomebaker_LDFLAGS = -export-dynamic
+ all: all-am
+
diff --git a/gnomebaker-0.6.4-libnotify-0.7.patch b/gnomebaker-0.6.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..27ae276d77a3
--- /dev/null
+++ b/gnomebaker-0.6.4-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+--- src/gblibnotify.c
++++ src/gblibnotify.c
+@@ -87,7 +87,15 @@
+ #ifdef HAVE_LIBNOTIFY
+ #if (LIBNOTIFY_VERSION_MINOR >= 3)
+ gint x, y;
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ global_notify = notify_notification_new (subject, content, "");
++#else
+ global_notify = notify_notification_new (subject, content, "", NULL);
++#endif
++#else
++ global_notify = notify_notification_new (subject, content, "", NULL);
++#endif
+ /* not sure if we have to free the pixbuf since it could be used internally in libnotify */
+ GdkPixbuf *icon_pixbuf = gbcommon_get_icon_for_name("gnomebaker-48", 48);
+ /* I think they changed the api between 0.3.0 and 0.3.1+ */
diff --git a/gnomebaker.install b/gnomebaker.install
new file mode 100644
index 000000000000..87adad50c12e
--- /dev/null
+++ b/gnomebaker.install
@@ -0,0 +1,24 @@
+pkgname=gnomebaker
+
+post_install() {
+ usr/sbin/gconfpkg --install ${pkgname}
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+pre_upgrade() {
+ pre_remove $1
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ usr/sbin/gconfpkg --uninstall ${pkgname}
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+} \ No newline at end of file