summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kojevnikov2015-06-28 03:12:26 +1000
committerAndrey Kojevnikov2015-06-28 03:12:26 +1000
commitde061d039d55a2ff0172bbac317a5ff272359c79 (patch)
tree7cb056def4a59e1f2c6d8ba516712fa1b4850758
downloadaur-de061d039d55a2ff0172bbac317a5ff272359c79.tar.gz
aur4
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD30
-rw-r--r--gns3.desktop11
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4df72466698f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gns3-gui
+ pkgdesc = GNS3 network simulator. Graphical user interface package.
+ pkgver = 1.3.7
+ pkgrel = 1
+ url = https://github.com/GNS3/gns3-gui
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-apache-libcloud
+ depends = python-paramiko
+ depends = python-requests
+ depends = python-raven
+ depends = python-sip
+ depends = gns3-converter
+ depends = python-pyqt4
+ optdepends = gns3-server: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.
+ optdepends = dynamips: Cisco router emulator.
+ optdepends = xterm: Default terminal emulator for CLI management of virtual instances.
+ optdepends = wireshark-gtk: Live packet capture.
+ conflicts = gns3
+ conflicts = gns3-git
+ source = gns3-gui-1.3.7.tar.gz::https://github.com/GNS3/gns3-gui/archive/v1.3.7.tar.gz
+ source = gns3.desktop
+ md5sums = 9e4eff79f41488f50273be3a11192be4
+ md5sums = ac6ba60be0a1cb7fc965d1a105e431d5
+
+pkgname = gns3-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..604fa509c35e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: korjjj <korjjj+aur[at]gmail[dot]com>
+
+pkgname=gns3-gui
+pkgver=1.3.7
+pkgrel=1
+pkgdesc='GNS3 network simulator. Graphical user interface package.'
+arch=('any')
+url='https://github.com/GNS3/gns3-gui'
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python-apache-libcloud' 'python-paramiko' 'python-requests' 'python-raven' 'python-sip' 'gns3-converter' 'python-pyqt4')
+optdepends=('gns3-server: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.'
+ 'dynamips: Cisco router emulator.'
+ 'xterm: Default terminal emulator for CLI management of virtual instances.'
+ 'wireshark-gtk: Live packet capture.')
+conflicts=('gns3' 'gns3-git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'gns3.desktop')
+md5sums=('9e4eff79f41488f50273be3a11192be4'
+ 'ac6ba60be0a1cb7fc965d1a105e431d5')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python setup.py install --root=${pkgdir} --optimize=1
+ install -Dm644 ${srcdir}/gns3.desktop ${pkgdir}/usr/share/applications/gns3.desktop
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/resources/images/gns3_icon_256x256.png ${pkgdir}/usr/share/pixmaps/gns3.png
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gns3.desktop b/gns3.desktop
new file mode 100644
index 000000000000..98458160ea83
--- /dev/null
+++ b/gns3.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=GNS3
+Comment=GNS3 network simulator
+Exec=gns3 %f
+Icon=gns3
+Terminal=false
+Categories=Education;
+MimeType=application/x-gns3;
+Keywords=simulator;network;netsim;