summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kojevnikov2015-06-28 03:12:10 +1000
committerAndrey Kojevnikov2015-06-28 03:12:10 +1000
commit051775590613003ac6381a3c8af4843d4640ec1e (patch)
treeb0f99b8e9e1f70e434eda557f05cad687ee2dde7
downloadaur-051775590613003ac6381a3c8af4843d4640ec1e.tar.gz
aur4
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD32
-rw-r--r--gns3-server.install13
-rw-r--r--gns3-server@.service10
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1db1ab2eb751
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gns3-server
+ pkgdesc = GNS3 network simulator. Server package.
+ pkgver = 1.3.7
+ pkgrel = 1
+ url = https://github.com/GNS3/gns3-server
+ install = gns3-server.install
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-netifaces
+ depends = python-jsonschema
+ depends = python-dateutil
+ depends = python-aiohttp
+ depends = python-jinja
+ depends = python-raven
+ optdepends = dynamips: Cisco router emulator.
+ optdepends = vboxwrapper: VirtualBox wrapper for GNS3.
+ optdepends = iouyap: Bridge IOU to UDP, TAP and Ethernet.
+ optdepends = qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.
+ optdepends = vpcs: Simple PC emulation for basic network operations.
+ optdepends = gns3-gui: graphical user interface for GNS3 server.
+ source = gns3-server-1.3.7.tar.gz::https://github.com/GNS3/gns3-server/archive/v1.3.7.tar.gz
+ source = gns3-server@.service
+ md5sums = 4549f94aeea503b2b431471c34da3a5c
+ md5sums = f602390385890dab14f68e5e0a8cac2d
+
+pkgname = gns3-server
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af1efcb01169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: korjjj <korjjj+aur[at]gmail[dot]com>
+
+pkgname=gns3-server
+pkgver=1.3.7
+pkgrel=1
+pkgdesc='GNS3 network simulator. Server package.'
+arch=('any')
+url='https://github.com/GNS3/gns3-server'
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python-netifaces' 'python-jsonschema' 'python-dateutil' 'python-aiohttp' 'python-jinja' 'python-raven')
+optdepends=('dynamips: Cisco router emulator.'
+ 'vboxwrapper: VirtualBox wrapper for GNS3.'
+ 'iouyap: Bridge IOU to UDP, TAP and Ethernet.'
+ 'qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.'
+ 'vpcs: Simple PC emulation for basic network operations.'
+ 'gns3-gui: graphical user interface for GNS3 server.'
+)
+install="${pkgname}.install"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}@.service")
+md5sums=('4549f94aeea503b2b431471c34da3a5c'
+ 'f602390385890dab14f68e5e0a8cac2d')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python setup.py install --root=${pkgdir} --optimize=1
+ install -Dm644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 ${srcdir}/${pkgname}@.service ${pkgdir}/usr/lib/systemd/system/${pkgname}@.service
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gns3-server.install b/gns3-server.install
new file mode 100644
index 000000000000..0e89e97e4e43
--- /dev/null
+++ b/gns3-server.install
@@ -0,0 +1,13 @@
+post_install() {
+cat << EOF
+ To enable and start gns3-server execute the following,
+ replacing 'USER' with your username:
+
+ systemctl enable gns3-server@USER
+ systemctl start gns3-server@USER
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/gns3-server@.service b/gns3-server@.service
new file mode 100644
index 000000000000..0d96e3fd4992
--- /dev/null
+++ b/gns3-server@.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=gns3 server for %i
+After=network.target
+
+[Service]
+User=%i
+ExecStart=/usr/bin/gns3server
+
+[Install]
+WantedBy=multi-user.target