summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2017-06-21 23:24:26 +0200
committerHyacinthe Cartiaux2017-06-21 23:24:26 +0200
commit0c15696f68ec1966bae28ffef9c85bba379eabf1 (patch)
tree04413c65756e11e4718f36e5c67b3ce17b1d03f4
parentfd6f294b0af7e6049c60796e44e5dc2e52bea7a4 (diff)
downloadaur-0c15696f68ec1966bae28ffef9c85bba379eabf1.tar.gz
Update to 2.0.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1171206a3c1b..6cb3e13ebd54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Jan 31 08:53:12 UTC 2017
+# Wed Jun 21 21:24:23 UTC 2017
pkgbase = gns3-server
pkgdesc = GNS3 network simulator. Server package.
- pkgver = 1.5.3
+ pkgver = 2.0.3
pkgrel = 1
url = https://github.com/GNS3/gns3-server
install = gns3-server.install
@@ -11,12 +11,14 @@ pkgbase = gns3-server
license = GPL3
makedepends = python-setuptools
depends = python-jsonschema
- depends = python-aiohttp
- depends = python-aiohttp-cors
+ depends = python-aiohttp-135
+ depends = python-aiohttp-cors-051
+ depends = python-yarl
depends = python-jinja
depends = python-raven
depends = python-psutil
depends = python-zipstream
+ depends = python-typing
optdepends = dynamips: Cisco router emulator.
optdepends = gns3-gui: graphical user interface for GNS3 server.
optdepends = vboxwrapper: VirtualBox wrapper for GNS3.
@@ -24,9 +26,9 @@ pkgbase = gns3-server
optdepends = qemu: Used by GNS3 to run Cisco ASA, PIX and IDS.
optdepends = vpcs: Simple PC emulation for basic network operations.
optdepends = ubridge: Bridge for UDP tunnels, Ethernet, TAP and VMnet interfaces.
- source = gns3-server-1.5.3.tar.gz::https://github.com/GNS3/gns3-server/archive/v1.5.3.tar.gz
+ source = gns3-server-2.0.3.tar.gz::https://github.com/GNS3/gns3-server/archive/v2.0.3.tar.gz
source = gns3-server@.service
- md5sums = 547481b2b22bf98a18f376ae66e08d22
+ md5sums = 63ae2f4c276aa5f6bf07f38b46372f0f
md5sums = f7a8f3128a903179c5f17a6c242b3cf9
pkgname = gns3-server
diff --git a/PKGBUILD b/PKGBUILD
index 52207bf02db3..f99d08e5f402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: korjjj <korjjj+aur[at]gmail[dot]com>
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: korjjj <korjjj+aur[at]gmail[dot]com>
pkgname=gns3-server
-pkgver=1.5.3
+pkgver=2.0.3
pkgrel=1
pkgdesc='GNS3 network simulator. Server package.'
arch=('any')
@@ -9,7 +10,7 @@ url='https://github.com/GNS3/gns3-server'
license=('GPL3')
groups=('gns3')
makedepends=('python-setuptools')
-depends=('python-jsonschema' 'python-aiohttp' 'python-aiohttp-cors' 'python-jinja' 'python-raven' 'python-psutil' 'python-zipstream')
+depends=('python-jsonschema' 'python-aiohttp-135' 'python-aiohttp-cors-051' 'python-yarl' 'python-jinja' 'python-raven' 'python-psutil' 'python-zipstream' 'python-typing')
optdepends=('dynamips: Cisco router emulator.'
'gns3-gui: graphical user interface for GNS3 server.'
'vboxwrapper: VirtualBox wrapper for GNS3.'
@@ -22,9 +23,15 @@ install="${pkgname}.install"
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
"${pkgname}@.service")
-md5sums=('547481b2b22bf98a18f376ae66e08d22'
+md5sums=('63ae2f4c276aa5f6bf07f38b46372f0f'
'f7a8f3128a903179c5f17a6c242b3cf9')
+prepare() {
+ sed -i 's/yarl>=0.9.8,<0.10/yarl>=0.10.2,<0.11/g' ${srcdir}/${pkgname}-${pkgver}/requirements.txt
+# sed -i 's/aiohttp>=1.3.5,<=1.4.0/aiohttp>=1.3.5/g' ${srcdir}/${pkgname}-${pkgver}/requirements.txt
+# sed -i 's/aiohttp-cors==0.5.1/aiohttp-cors>=0.5.1/g' ${srcdir}/${pkgname}-${pkgver}/requirements.txt
+}
+
package() {
cd ${srcdir}/${pkgname}-${pkgver}
python setup.py install --root=${pkgdir} --optimize=1