summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-04-11 09:08:03 +0530
committerKeshav Amburay2013-04-11 09:08:03 +0530
commit51318c5483a0f1640780d6aec75da529fe3128f8 (patch)
treed7d7fd3c1d3f010871e231e4da0cd195241ba457
parentc0e8d6588787446894653166226724b2dfe4353f (diff)
downloadaur-51318c5483a0f1640780d6aec75da529fe3128f8.tar.gz
Adapt PKGBUILD to pacman/makepkg 4.1 - 2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--gnu-efi-fedora-IA32-build-fix.patch26
3 files changed, 3 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fec74527e58..46e3282bb73e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnu-efi-libs-fedora-git
pkgdesc = Library for building x86_64 and i386 UEFI Applications using GNU toolchain - Fedora GIT Version
- pkgver = 20130411
+ pkgver = 51ddcca
pkgrel = 1
url = http://sourceforge.net/projects/gnu-efi/
arch = i686
@@ -14,12 +14,10 @@ pkgbase = gnu-efi-libs-fedora-git
source = gnu-efi-fedora::git+git://github.com/vathpela/gnu-efi.git#branch=fedora
source = gnu-efi-fix-x86_64-uefi-call-wrapper.patch
source = gnu-efi-fedora-disable-USE_MS_ABI.patch
- source = gnu-efi-fedora-IA32-build-fix.patch
source = gnu-efi-fedora-fix-makefile-vars.patch
sha1sums = SKIP
sha1sums = 8918de3aefba2a3dc367bbb28611394c4c300a6d
sha1sums = 5e6b30cdf2c1d89ccb3f5314bb3e0ef0d45b0001
- sha1sums = 51ac3eb4667f75dd50acbc3b8805f75fa64b4d7e
sha1sums = 09144dd3ec664b96714fe92d823e31bd1bb747e9
pkgname = gnu-efi-libs-fedora-git
diff --git a/PKGBUILD b/PKGBUILD
index df6319a6d54c..eb5aea885e89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
pkgname="gnu-efi-libs-fedora-git"
-pkgver=20130411
-pkgrel="1"
+pkgver=51ddcca
+pkgrel=1
pkgdesc="Library for building x86_64 and i386 UEFI Applications using GNU toolchain - Fedora GIT Version"
url="http://sourceforge.net/projects/gnu-efi/"
license=('GPL')
@@ -26,13 +26,11 @@ _gitbranch="fedora"
source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}"
'gnu-efi-fix-x86_64-uefi-call-wrapper.patch'
'gnu-efi-fedora-disable-USE_MS_ABI.patch'
- 'gnu-efi-fedora-IA32-build-fix.patch'
'gnu-efi-fedora-fix-makefile-vars.patch')
sha1sums=('SKIP'
'8918de3aefba2a3dc367bbb28611394c4c300a6d'
'5e6b30cdf2c1d89ccb3f5314bb3e0ef0d45b0001'
- '51ac3eb4667f75dd50acbc3b8805f75fa64b4d7e'
'09144dd3ec664b96714fe92d823e31bd1bb747e9')
pkgver() {
@@ -108,10 +106,6 @@ build() {
patch -Np1 -i "${srcdir}/gnu-efi-fedora-disable-USE_MS_ABI.patch"
echo
- ## Fix missing header file for IA32 build
- patch -Np1 -i "${srcdir}/gnu-efi-fedora-IA32-build-fix.patch"
- echo
-
## Fix Makefiles to enable compile for both UEFI arch
patch -Np1 -i "${srcdir}/gnu-efi-fedora-fix-makefile-vars.patch"
echo
diff --git a/gnu-efi-fedora-IA32-build-fix.patch b/gnu-efi-fedora-IA32-build-fix.patch
deleted file mode 100644
index bfc89d13f1d1..000000000000
--- a/gnu-efi-fedora-IA32-build-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/inc/ia32/efibind.h b/inc/ia32/efibind.h
-index dc64e49..36360a4 100644
---- a/inc/ia32/efibind.h
-+++ b/inc/ia32/efibind.h
-@@ -75,6 +75,8 @@ Revision History
- typedef unsigned char uint8_t;
- typedef char int8_t;
- #endif
-+#elif defined(__GNUC__)
-+ #include <stdint-gcc.h>
- #endif
-
- //
-diff --git a/inc/ia64/efibind.h b/inc/ia64/efibind.h
-index 871a1df..d936257 100644
---- a/inc/ia64/efibind.h
-+++ b/inc/ia64/efibind.h
-@@ -62,6 +62,8 @@ Revision History
- typedef unsigned char uint8_t;
- typedef char int8_t;
- #endif
-+#elif defined(__GNUC__)
-+ #include <stdint-gcc.h>
- #endif
-
- //