summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-04-29 16:30:24 +0530
committerKeshav Amburay2013-04-29 16:30:24 +0530
commit8b9ac5dfdc38bf05b3be79bfb601c6611852d2c0 (patch)
treeda3d9b06d1529093591152cf88c31eeb0de070a4
parent60804f5d9c9dee12a1e9d45c79fbacaefd1df643 (diff)
downloadaur-8b9ac5dfdc38bf05b3be79bfb601c6611852d2c0.tar.gz
M
-rw-r--r--PKGBUILD24
1 files changed, 1 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e4721765761..00ce74d83856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,32 +34,10 @@ sha1sums=('SKIP'
'09144dd3ec664b96714fe92d823e31bd1bb747e9')
pkgver() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${_gitname}/"
git describe --always | sed 's|-|.|g'
}
-_update_git() {
- cd "${srcdir}/"
-
- msg "Connecting to GIT server...."
-
- if [[ -d "${srcdir}/${_gitname}/" ]]; then
- cd "${srcdir}/${_gitname}/"
- git reset --hard
- git fetch
- git checkout "${_gitbranch}"
- git merge "remotes/origin/${_gitbranch}"
- msg "The local GIT repo has been updated."
- else
- git clone "${_gitroot}" "${_gitname}"
- cd "${srcdir}/${_gitname}/"
- git checkout "${_gitbranch}"
- msg "GIT checkout done or server timeout"
- fi
-
- echo
-}
-
_build_gnu-efi-libs-x86_64() {
cp -r "${srcdir}/${_gitname}_build" "${srcdir}/${_gitname}_build-x86_64"
cd "${srcdir}/${_gitname}_build-x86_64/"