summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2013-06-12 22:43:29 +0530
committerKeshav Amburay2013-06-12 22:43:29 +0530
commit9eba04d0925f75725d66c94af4c74fb99c23152d (patch)
tree0e8317bd0f23bb44b0de7ef2189cfed9427934ba
parent20339d229092eda68fcd6693199965a80bf3399c (diff)
downloadaur-9eba04d0925f75725d66c94af4c74fb99c23152d.tar.gz
Update patches
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD60
-rw-r--r--gnu-efi-disable-USE_MS_ABI.patch16
-rw-r--r--gnu-efi-disable-mmx-and-sse.patch53
-rw-r--r--gnu-efi-disable-use_ms_abi.patch13
-rw-r--r--gnu-efi-fix-makefile-vars.patch23
6 files changed, 41 insertions, 136 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 162cb048ed5e..e1658af01456 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnu-efi-libs-git
- pkgdesc = Library for building x86_64 and i386 UEFI Applications using GNU toolchain - Fedora GIT Version
- pkgver = 0ca0dac
+ pkgdesc = Library for building x86_64 and ia32 UEFI Applications using GNU toolchain - Sourceforge GIT Version
+ pkgver = 8cb1e87
pkgrel = 1
url = http://sourceforge.net/projects/gnu-efi/
arch = i686
@@ -12,13 +12,9 @@ pkgbase = gnu-efi-libs-git
options = !strip
options = !makeflags
source = gnu-efi::git+git://git.code.sf.net/p/gnu-efi/code#branch=master
- source = gnu-efi-fix-makefile-vars.patch
- source = gnu-efi-disable-mmx-and-sse.patch
- source = gnu-efi-disable-USE_MS_ABI.patch
+ source = gnu-efi-disable-use_ms_abi.patch
sha1sums = SKIP
- sha1sums = eec2b954aa44407b38342be567e767cea302b7c8
- sha1sums = 9c9ed8bc8bf76105302b9d57a516f3bab5d6ffa9
- sha1sums = 5e6b30cdf2c1d89ccb3f5314bb3e0ef0d45b0001
+ sha1sums = e9f2c6cc7414b021cd3297791f911f721f120afa
pkgname = gnu-efi-libs-git
diff --git a/PKGBUILD b/PKGBUILD
index 60f1c11f1a52..9f249ab393c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@ _gitroot="git://git.code.sf.net/p/gnu-efi/code"
_gitname="gnu-efi"
_gitbranch="master"
-_src_rootdir="gnu-efi-3.0"
+_src_rootdir="${_gitname}-3.0"
pkgname="gnu-efi-libs-git"
-pkgver=0ca0dac
+pkgver=8cb1e87
pkgrel=1
-pkgdesc="Library for building x86_64 and i386 UEFI Applications using GNU toolchain - Fedora GIT Version"
+pkgdesc="Library for building x86_64 and ia32 UEFI Applications using GNU toolchain - Sourceforge GIT Version"
url="http://sourceforge.net/projects/gnu-efi/"
license=('GPL')
arch=('i686' 'x86_64')
@@ -26,14 +26,10 @@ conflicts=('gnu-efi-libs')
provides=('gnu-efi-libs')
source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}"
- 'gnu-efi-fix-makefile-vars.patch'
- 'gnu-efi-disable-mmx-and-sse.patch'
- 'gnu-efi-disable-USE_MS_ABI.patch')
+ 'gnu-efi-disable-use_ms_abi.patch')
sha1sums=('SKIP'
- 'eec2b954aa44407b38342be567e767cea302b7c8'
- '9c9ed8bc8bf76105302b9d57a516f3bab5d6ffa9'
- '5e6b30cdf2c1d89ccb3f5314bb3e0ef0d45b0001')
+ 'e9f2c6cc7414b021cd3297791f911f721f120afa')
pkgver() {
cd "${srcdir}/${_gitname}/"
@@ -52,18 +48,18 @@ _build_gnu-efi-libs-x86_64() {
unset LDFLAGS
unset MAKEFLAGS
- ARCH="x86_64" make -j1
+ make ARCH="x86_64" -j1
echo
- ARCH="x86_64" make -j1 -C apps all
+ make ARCH="x86_64" -j1 -C apps all
echo
}
-_build_gnu-efi-libs-i386() {
- rm -rf "${srcdir}/${_gitname}_build-i386" || true
- cp -r "${srcdir}/${_gitname}_build" "${srcdir}/${_gitname}_build-i386"
+_build_gnu-efi-libs-ia32() {
+ rm -rf "${srcdir}/${_gitname}_build-ia32" || true
+ cp -r "${srcdir}/${_gitname}_build" "${srcdir}/${_gitname}_build-ia32"
- cd "${srcdir}/${_gitname}_build-i386/${_src_rootdir}/"
+ cd "${srcdir}/${_gitname}_build-ia32/${_src_rootdir}/"
unset CFLAGS
unset CPPFLAGS
@@ -71,10 +67,10 @@ _build_gnu-efi-libs-i386() {
unset LDFLAGS
unset MAKEFLAGS
- ARCH="ia32" make -j1
+ make ARCH="ia32" -j1
echo
- ARCH="ia32" make -j1 -C apps all
+ make ARCH="ia32" -j1 -C apps all
echo
}
@@ -84,23 +80,15 @@ build() {
cd "${srcdir}/${_gitname}_build/${_src_rootdir}/"
- ## Fix Makefiles to enable compile for both UEFI arch
- patch -Np1 -i "${srcdir}/gnu-efi-fix-makefile-vars.patch" || true
- echo
-
- ## Disable MMX and SSE in GCC 4.8
- patch -Np1 -i "${srcdir}/gnu-efi-disable-mmx-and-sse.patch" || true
- echo
-
- ## Disable GCC MS_ABI CFLAGS
- # patch -Np1 -i "${srcdir}/gnu-efi-disable-USE_MS_ABI.patch" || true
+ ## Disable ms_abi in gnu-efi Makefiles
+ # patch -Np1 -i "${srcdir}/gnu-efi-disable-use_ms_abi.patch"
# echo
if [[ "${CARCH}" == "x86_64" ]]; then
_build_gnu-efi-libs-x86_64
fi
- _build_gnu-efi-libs-i386
+ _build_gnu-efi-libs-ia32
}
_package_gnu-efi-libs-x86_64() {
@@ -109,18 +97,18 @@ _package_gnu-efi-libs-x86_64() {
make ARCH="x86_64" INSTALLROOT="${pkgdir}" PREFIX="/usr" LIBDIR="/usr/lib" install
echo
- install -d "${pkgdir}/usr/share/gnu-efi/x86_64/"
- install -D -m0644 "${srcdir}/${_gitname}_build-x86_64/${_src_rootdir}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/x86_64/"
+ install -d "${pkgdir}/usr/share/gnu-efi/apps/x86_64/"
+ install -D -m0644 "${srcdir}/${_gitname}_build-x86_64/${_src_rootdir}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/apps/x86_64/"
}
-_package_gnu-efi-libs-i386() {
- cd "${srcdir}/${_gitname}_build-i386/${_src_rootdir}/"
+_package_gnu-efi-libs-ia32() {
+ cd "${srcdir}/${_gitname}_build-ia32/${_src_rootdir}/"
make ARCH="ia32" INSTALLROOT="${pkgdir}" PREFIX="/usr" LIBDIR="/usr/${_LIBDIR32}" install
echo
- install -d "${pkgdir}/usr/share/gnu-efi/i386/"
- install -D -m0644 "${srcdir}/${_gitname}_build-i386/${_src_rootdir}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/i386/"
+ install -d "${pkgdir}/usr/share/gnu-efi/apps/ia32/"
+ install -D -m0644 "${srcdir}/${_gitname}_build-ia32/${_src_rootdir}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/apps/ia32/"
}
package() {
@@ -128,9 +116,9 @@ package() {
_package_gnu-efi-libs-x86_64
_LIBDIR32="lib32"
- _package_gnu-efi-libs-i386
+ _package_gnu-efi-libs-ia32
else
_LIBDIR32="lib"
- _package_gnu-efi-libs-i386
+ _package_gnu-efi-libs-ia32
fi
}
diff --git a/gnu-efi-disable-USE_MS_ABI.patch b/gnu-efi-disable-USE_MS_ABI.patch
deleted file mode 100644
index e363e6481fea..000000000000
--- a/gnu-efi-disable-USE_MS_ABI.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/Make.defaults b/Make.defaults
-index 38da180..aa1f4de 100644
---- a/Make.defaults
-+++ b/Make.defaults
-@@ -54,9 +54,9 @@ GCCNEWENOUGH := $(shell ([ $(GCCVERSION) -gt "4" ] || ([ $(GCCVERSION) -eq "4" ]
-
- CPPFLAGS = -DCONFIG_$(ARCH)
- ifeq ($(GCCNEWENOUGH),1)
--CPPFLAGS += -DGNU_EFI_USE_MS_ABI -maccumulate-outgoing-args --std=c11
-+CPPFLAGS += -maccumulate-outgoing-args --std=c11
- endif
--CFLAGS = $(ARCH3264) -O2 -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants
-+CFLAGS = $(ARCH3264) -O2 -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-stack-protector -fno-merge-constants
- ASFLAGS = $(ARCH3264)
- LDFLAGS = -nostdlib
- INSTALL = install
diff --git a/gnu-efi-disable-mmx-and-sse.patch b/gnu-efi-disable-mmx-and-sse.patch
deleted file mode 100644
index 563661bec796..000000000000
--- a/gnu-efi-disable-mmx-and-sse.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From d703c370c78578b63e7b5e04a3801c7f5fbf0c94 Mon Sep 17 00:00:00 2001
-From: Peter Jones <pjones@redhat.com>
-Date: Fri, 31 May 2013 15:00:11 -0400
-Subject: [PATCH] Disable MMX and SSE.
-
-GCC 4.8.0 adds some optimizations that will use movups/movaps (and use
-%xmm* registers) when they're faster, and of course that won't work at
-all since UEFI firmwares aren't guaranteed to initialize the mmx/sse
-instructions.
-
-This will be even more annoying, since most UEFI firmwares don't
-initialize the #DE or #UD trap handlers, and your backtrace will be a
-random path through uninitialized memory, occasionally including
-whatever address the IDT has for #UD, but also addresses like "0x4" and
-"0x507" that you don't normally expect to see in your call path.
----
- Make.defaults | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/Make.defaults b/Make.defaults
-index 0585915..ea7513e 100644
---- a/Make.defaults
-+++ b/Make.defaults
-@@ -60,7 +60,9 @@ CPPFLAGS = -DCONFIG_$(ARCH)
- ifeq ($(GCCNEWENOUGH),1)
- CPPFLAGS += -DGNU_EFI_USE_MS_ABI -maccumulate-outgoing-args --std=c11
- endif
--CFLAGS = $(ARCH3264) -O2 -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -ffreestanding -fno-stack-protector -fno-stack-check
-+CFLAGS = $(ARCH3264) -O2 -fpic -Wall -fshort-wchar -fno-strict-aliasing \
-+ -fno-merge-constants -ffreestanding -fno-stack-protector \
-+ -fno-stack-check
- ASFLAGS = $(ARCH3264)
- LDFLAGS = -nostdlib --no-undefined
- INSTALL = install
-@@ -78,13 +80,14 @@ ifeq ($(ARCH),ia64)
- endif
-
- ifeq ($(ARCH), ia32)
-+ CFLAGS += -mno-mmx -mno-sse
- ifeq ($(HOSTARCH), x86_64)
- ARCH3264 = -m32
- endif
- endif
-
- ifeq ($(ARCH), x86_64)
-- CFLAGS += -mno-red-zone
-+ CFLAGS += -mno-red-zone -mno-mmx -mno-sse
- ifeq ($(HOSTARCH), ia32)
- ARCH3264 = -m64
- endif
---
-1.8.2.1
-
diff --git a/gnu-efi-disable-use_ms_abi.patch b/gnu-efi-disable-use_ms_abi.patch
new file mode 100644
index 000000000000..dbb48d3f892c
--- /dev/null
+++ b/gnu-efi-disable-use_ms_abi.patch
@@ -0,0 +1,13 @@
+diff --git a/gnu-efi-3.0/Make.defaults b/gnu-efi-3.0/Make.defaults
+index a22a1b4..4c95e7b 100644
+--- a/gnu-efi-3.0/Make.defaults
++++ b/gnu-efi-3.0/Make.defaults
+@@ -83,7 +83,7 @@ GCCNEWENOUGH := $(shell ( [ $(GCCVERSION) -gt "4" ] \
+ && [ $(GCCMINOR) -ge "7" ] ) ) \
+ && echo 1)
+ ifeq ($(GCCNEWENOUGH),1)
+- CPPFLAGS += -DGNU_EFI_USE_MS_ABI -maccumulate-outgoing-args --std=c11
++ CPPFLAGS += --std=c11
+ endif
+
+ # Arch-specific compilation flags
diff --git a/gnu-efi-fix-makefile-vars.patch b/gnu-efi-fix-makefile-vars.patch
deleted file mode 100644
index 99e85ab3e081..000000000000
--- a/gnu-efi-fix-makefile-vars.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/Make.defaults b/Make.defaults
-index 0585915..ccada22 100644
---- a/Make.defaults
-+++ b/Make.defaults
-@@ -38,14 +38,14 @@
- # Where to install the package. GNU-EFI will create and access
- # lib and include under the root
- #
--INSTALLROOT := /
--PREFIX := /usr/local
--LIBDIR := ${PREFIX}/lib
-+INSTALLROOT ?= /
-+PREFIX ?= /usr/local
-+LIBDIR ?= ${PREFIX}/lib
-
- TOPDIR := $(shell if [ "$$PWD" != "" ]; then echo $$PWD; else pwd; fi)
-
- HOSTARCH = $(shell uname -m | sed s,i[3456789]86,ia32,)
--ARCH := $(shell uname -m | sed s,i[3456789]86,ia32,)
-+ARCH ?= $(shell uname -m | sed s,i[3456789]86,ia32,)
- # FreeBSD (and possibly others) reports amd64 instead of x86_64
- ifeq ($(ARCH), amd64)
- ARCH = x86_64