summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2015-06-08 21:02:11 -0400
committerKeshav Amburay2015-06-08 21:02:11 -0400
commitaf5f9eb058a748148bef3cf41912c93820c829a3 (patch)
tree852df087e7bd8654c3b95f1ad36f97baff31000e
parent9a9338538ac14a49e7db29b9432f7fa3ab74eeaa (diff)
downloadaur-af5f9eb058a748148bef3cf41912c93820c829a3.tar.gz
Bump pkgver
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD31
-rw-r--r--gnu-efi-3.0v-revert-makefile-commit.patch148
3 files changed, 15 insertions, 174 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4779c1ed8c7c..d83b08282abe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnu-efi-libs-git
- pkgdesc = Library for building UEFI Applications using GNU toolchain - Sourceforge GIT Version
- pkgver = 3.0v.43.f16d93f
+ pkgdesc = Library for building UEFI Applications using GNU toolchain - GIT Version
+ pkgver = 3.0.2.81.d4c242e
pkgrel = 1
url = http://sourceforge.net/projects/gnu-efi/
arch = x86_64
@@ -8,15 +8,13 @@ pkgbase = gnu-efi-libs-git
license = GPL
makedepends = git
makedepends = pciutils
- provides = gnu-efi-libs=3.0v.43.f16d93f
+ provides = gnu-efi-libs=3.0.2.81.d4c242e
conflicts = gnu-efi-libs
options = staticlibs
options = !strip
options = !makeflags
- source = gnu-efi::git+http://git.code.sf.net/p/gnu-efi/code#branch=master
- source = gnu-efi-3.0v-revert-makefile-commit.patch
+ source = gnu-efi::git+https://github.com/vathpela/gnu-efi.git#branch=fedora
sha1sums = SKIP
- sha1sums = db411a1f2f545924dc59f8a0c2331acfcb10bb54
pkgname = gnu-efi-libs-git
diff --git a/PKGBUILD b/PKGBUILD
index f3c9b2649d09..bcb5af3f49ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,14 @@
[[ "${CARCH}" == "i686" ]] && _EFI_ARCH="ia32"
__pkgname="gnu-efi"
-
-_src_rootdir="${__pkgname}-3.0"
-
_pkgname="gnu-efi-libs"
pkgname="${_pkgname}-git"
-_pkgver="3.0v"
-pkgver=3.0v.43.f16d93f
+_pkgver="3.0.2"
+pkgver=3.0.2.81.d4c242e
pkgrel=1
-pkgdesc="Library for building UEFI Applications using GNU toolchain - Sourceforge GIT Version"
+pkgdesc="Library for building UEFI Applications using GNU toolchain - GIT Version"
url="http://sourceforge.net/projects/gnu-efi/"
license=('GPL')
arch=('x86_64' 'i686')
@@ -26,11 +23,8 @@ options=('staticlibs' '!strip' '!makeflags')
conflicts=('gnu-efi-libs')
provides=("gnu-efi-libs=${pkgver}")
-source=("${__pkgname}::git+http://git.code.sf.net/p/gnu-efi/code#branch=master"
- 'gnu-efi-3.0v-revert-makefile-commit.patch')
-
-sha1sums=('SKIP'
- 'db411a1f2f545924dc59f8a0c2331acfcb10bb54')
+source=("gnu-efi::git+https://github.com/vathpela/gnu-efi.git#branch=fedora")
+sha1sums=('SKIP')
pkgver() {
cd "${srcdir}/${__pkgname}/"
@@ -49,18 +43,15 @@ prepare() {
echo
msg "Fix Makefiles"
- # git revert --no-commit 06744d69273de4945cf0ffcaa4a6abf7cec707b6
- patch -Np1 -i "${srcdir}/gnu-efi-3.0v-revert-makefile-commit.patch" || true
- echo
-
- msg "Fix stdarg.h issue"
- sed 's|#include "stdarg.h"|#include <stdarg.h>|g' -i "${srcdir}/${__pkgname}_build/${_src_rootdir}/inc/efistdarg.h" || true
+ sed 's|/gnuefi/crt0-efi|/x86_64/gnuefi/crt0-efi|g' -i "${srcdir}/${__pkgname}_build/apps/Makefile"
+ sed 's|L../lib|L../x86_64/lib|g' -i "${srcdir}/${__pkgname}_build/apps/Makefile"
+ sed 's|L../gnuefi|L../x86_64/gnuefi|g' -i "${srcdir}/${__pkgname}_build/apps/Makefile"
}
build() {
- cd "${srcdir}/${__pkgname}_build/${_src_rootdir}/"
+ cd "${srcdir}/${__pkgname}_build/"
msg "Unset all compiler FLAGS"
unset CFLAGS
@@ -81,7 +72,7 @@ build() {
package() {
- cd "${srcdir}/${__pkgname}_build/${_src_rootdir}/"
+ cd "${srcdir}/${__pkgname}_build/"
msg "Run make install"
make INSTALLROOT="${pkgdir}" PREFIX="/usr" LIBDIR="/usr/lib" install
@@ -89,6 +80,6 @@ package() {
msg "Install gnu-efi apps"
install -d "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
- install -D -m0644 "${srcdir}/${__pkgname}_build/${_src_rootdir}/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
+ install -D -m0644 "${srcdir}/${__pkgname}_build/apps"/*.efi "${pkgdir}/usr/share/gnu-efi/apps/${_EFI_ARCH}/"
}
diff --git a/gnu-efi-3.0v-revert-makefile-commit.patch b/gnu-efi-3.0v-revert-makefile-commit.patch
deleted file mode 100644
index 4e15b8956c0f..000000000000
--- a/gnu-efi-3.0v-revert-makefile-commit.patch
+++ /dev/null
@@ -1,148 +0,0 @@
-From 3100a29932662dd8b045ca0a2c3329e67b2b2df3 Mon Sep 17 00:00:00 2001
-From: Keshav Amburay <the.ridikulus.rat@gmail.com>
-Date: Tue, 13 May 2014 14:14:31 -0400
-Subject: [PATCH] Revert 06744d69273de4945cf0ffcaa4a6abf7cec707b6
-
----
- gnu-efi-3.0/gnuefi/Makefile | 34 ++++++++++++----------------------
- gnu-efi-3.0/inc/Makefile | 36 +++++++++++-------------------------
- gnu-efi-3.0/lib/Makefile | 13 +++----------
- 3 files changed, 26 insertions(+), 57 deletions(-)
-
-diff --git a/gnu-efi-3.0/gnuefi/Makefile b/gnu-efi-3.0/gnuefi/Makefile
-index 71e93f9..27f43b7 100644
---- a/gnu-efi-3.0/gnuefi/Makefile
-+++ b/gnu-efi-3.0/gnuefi/Makefile
-@@ -49,19 +49,6 @@ OBJS = $(FILES:%=%.o)
-
- TARGETS = crt0-efi-$(ARCH).o libgnuefi.a
-
--INSTALLTARGETS = $(TARGETS)
--ifneq (,$(findstring FreeBSD,$(OS)))
-- ifeq ($(ARCH),x86_64)
-- INSTALLTARGETS += elf_$(ARCH)_fbsd_efi.lds
-- else
-- INSTALLTARGETS += elf_$(ARCH)_efi.lds
-- endif
--else
-- INSTALLTARGETS += elf_$(ARCH)_efi.lds
--endif
--
--LIBDIRINSTALL = $(INSTALLROOT)/$(LIBDIR)
--
- all: $(TARGETS)
-
- libgnuefi.a: $(patsubst %,libgnuefi.a(%),$(OBJS))
-@@ -69,14 +56,17 @@ libgnuefi.a: $(patsubst %,libgnuefi.a(%),$(OBJS))
- clean:
- rm -f $(TARGETS) *~ *.o $(OBJS)
-
--$(LIBDIRINSTALL):
-- mkdir -p $@
--
--.SECONDEXPANSION:
--
--$(LIBDIRINSTALL)/%: % | $$(dir $$@)
-- $(INSTALL) -m 644 $< $(dir $@)
--
--install: $(addprefix $(LIBDIRINSTALL)/,$(INSTALLTARGETS))
-+install:
-+ mkdir -p $(INSTALLROOT)/$(LIBDIR)
-+ $(INSTALL) -m 644 $(TARGETS) $(INSTALLROOT)/$(LIBDIR)
-+ifneq (,$(findstring FreeBSD,$(OS)))
-+ ifeq ($(ARCH),x86_64)
-+ $(INSTALL) -m 644 $(SRCDIR)/elf_$(ARCH)_fbsd_efi.lds $(INSTALLROOT)/$(LIBDIR)
-+ else
-+ $(INSTALL) -m 644 $(SRCDIR)/elf_$(ARCH)_efi.lds $(INSTALLROOT)/$(LIBDIR)
-+ endif
-+else
-+ $(INSTALL) -m 644 $(SRCDIR)/elf_$(ARCH)_efi.lds $(INSTALLROOT)/$(LIBDIR)
-+endif
-
- include $(SRCDIR)/../Make.rules
-diff --git a/gnu-efi-3.0/inc/Makefile b/gnu-efi-3.0/inc/Makefile
-index 526af22..273d303 100644
---- a/gnu-efi-3.0/inc/Makefile
-+++ b/gnu-efi-3.0/inc/Makefile
-@@ -8,34 +8,20 @@ TOPDIR = $(SRCDIR)/..
-
- CDIR=$(TOPDIR)/..
-
--INCDIRINSTALL = $(INSTALLROOT)$(PREFIX)/include/efi
--
--SRCHEADERS = $(wildcard $(SRCDIR)/*.h) \
-- $(wildcard $(SRCDIR)/protocol/*.h) \
-- $(wildcard $(SRCDIR)/$(ARCH)/*.h)
--ifeq ($(ARCH),ia64)
-- SRCHEADERS += $(wildcard $(SRCDIR)/protocol/$(ARCH)/*.h)
--endif
--
--HEADERS = $(patsubst $(SRCDIR)/%,%,$(SRCHEADERS))
--
- all:
-
- clean:
-
-- rm -f *~
--
--$(INCDIRINSTALL) \
--$(INCDIRINSTALL)/protocol \
--$(INCDIRINSTALL)/$(ARCH) \
--$(INCDIRINSTALL)/protocol/$(ARCH):
-- mkdir -p $@
--
--.SECONDEXPANSION:
--
--$(INCDIRINSTALL)/%.h: %.h | $$(dir $$@)
-- $(INSTALL) -m 644 $< $(dir $@)
--
--install: $(addprefix $(INCDIRINSTALL)/,$(HEADERS))
-+install:
-+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi
-+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/protocol
-+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/$(ARCH)
-+ $(INSTALL) -m 644 $(SRCDIR)/*.h $(INSTALLROOT)$(PREFIX)/include/efi
-+ $(INSTALL) -m 644 $(SRCDIR)/protocol/*.h $(INSTALLROOT)$(PREFIX)/include/efi/protocol
-+ $(INSTALL) -m 644 $(SRCDIR)/$(ARCH)/*.h $(INSTALLROOT)$(PREFIX)/include/efi/$(ARCH)
-+ifeq ($(ARCH),ia64)
-+ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/protocol/ia64
-+ $(INSTALL) -m 644 $(SRCDIR)/protocol/ia64/*.h $(INSTALLROOT)$(PREFIX)/include/efi/protocol/ia64
-+endif
-
- include $(SRCDIR)/../Make.rules
-diff --git a/gnu-efi-3.0/lib/Makefile b/gnu-efi-3.0/lib/Makefile
-index d2635ad..e9f604e 100644
---- a/gnu-efi-3.0/lib/Makefile
-+++ b/gnu-efi-3.0/lib/Makefile
-@@ -61,11 +61,8 @@ OBJS = $(FILES:%=%.o)
-
- SUBDIRS = ia32 x86_64 ia64 runtime
-
--LIBDIRINSTALL = $(INSTALLROOT)/$(LIBDIR)
--
- all: libsubdirs libefi.a
-
--.PHONY: libsubdirs
- libsubdirs:
- for sdir in $(SUBDIRS); do mkdir -p $$sdir; done
-
-@@ -74,13 +71,9 @@ libefi.a: $(patsubst %,libefi.a(%),$(OBJS))
- clean:
- rm -f libefi.a *~ $(OBJS) */*.o
-
--$(LIBDIRINSTALL):
-- mkdir -p $@
--
--$(LIBDIRINSTALL)/libefi.a: libefi.a | $(LIBDIRINSTALL)
-- $(INSTALL) -m 644 $< $(dir $@)
--
--install: $(LIBDIRINSTALL)/libefi.a
-+install: libefi.a
-+ mkdir -p $(INSTALLROOT)/$(LIBDIR)
-+ $(INSTALL) -m 644 libefi.a $(INSTALLROOT)/$(LIBDIR)
-
- include $(SRCDIR)/../Make.rules
-
---
-1.9.2
-