summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeshav Amburay2014-05-13 14:17:50 -0400
committerKeshav Amburay2014-05-13 14:17:50 -0400
commiteafadc95ef104d3680b4a3e943243ffe7e7bd775 (patch)
tree4f04624614f9eb727620a2fbc645035a5d208ae6
parent5f33c4426fea90d4d464eb8168578b248ea5ec70 (diff)
downloadaur-eafadc95ef104d3680b4a3e943243ffe7e7bd775.tar.gz
Add patch to revert makefile commit
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
-rw-r--r--gnu-efi-3.0v-revert-makefile-commit.patch148
4 files changed, 160 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ce4c405c4c0..75aedd04fc8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnu-efi-libs-git
pkgdesc = Library for building UEFI Applications using GNU toolchain - Sourceforge GIT Version
- pkgver = 0.35.3c62e78
+ pkgver = 0.41.8921ba2
pkgrel = 1
url = http://sourceforge.net/projects/gnu-efi/
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = gnu-efi-libs-git
options = !strip
options = !makeflags
source = gnu-efi::git+http://git.code.sf.net/p/gnu-efi/code#branch=master
+ source = gnu-efi-3.0v-revert-makefile-commit.patch
sha1sums = SKIP
+ sha1sums = db411a1f2f545924dc59f8a0c2331acfcb10bb54
pkgname = gnu-efi-libs-git
diff --git a/.gitignore b/.gitignore
index 052b8ece5212..3828b21684d8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,3 +4,4 @@ pkg/
*.tar.gz
*.sig
*.log*
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
index bb6c66636017..c6115d0a0b77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ _gitbranch="master"
_src_rootdir="${_gitname}-3.0"
pkgname="gnu-efi-libs-git"
-pkgver=0.35.3c62e78
+pkgver=0.41.8921ba2
pkgrel=1
pkgdesc="Library for building UEFI Applications using GNU toolchain - Sourceforge GIT Version"
url="http://sourceforge.net/projects/gnu-efi/"
@@ -21,8 +21,11 @@ options=('staticlibs' '!strip' '!makeflags')
conflicts=('gnu-efi-libs')
provides=('gnu-efi-libs')
-source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}")
-sha1sums=('SKIP')
+source=("${_gitname}::git+${_gitroot}#branch=${_gitbranch}"
+ 'gnu-efi-3.0v-revert-makefile-commit.patch')
+
+sha1sums=('SKIP'
+ 'db411a1f2f545924dc59f8a0c2331acfcb10bb54')
pkgver() {
cd "${srcdir}/${_gitname}/"
@@ -41,7 +44,8 @@ build() {
git clean -x -d -f
echo
- git revert --no-commit 06744d69273de4945cf0ffcaa4a6abf7cec707b6
+ # git revert --no-commit 06744d69273de4945cf0ffcaa4a6abf7cec707b6
+ patch -Np1 -i "${srcdir}/gnu-efi-3.0v-revert-makefile-commit.patch" || true
echo
## Unset all compiler FLAGS
diff --git a/gnu-efi-3.0v-revert-makefile-commit.patch b/gnu-efi-3.0v-revert-makefile-commit.patch
new file mode 100644
index 000000000000..4e15b8956c0f
--- /dev/null
+++ b/gnu-efi-3.0v-revert-makefile-commit.patch
@@ -0,0 +1,148 @@
+From 3100a29932662dd8b045ca0a2c3329e67b2b2df3 Mon Sep 17 00:00:00 2001
+From: Keshav Amburay <the.ridikulus.rat@gmail.com>
+Date: Tue, 13 May 2014 14:14:31 -0400
+Subject: [PATCH] Revert 06744d69273de4945cf0ffcaa4a6abf7cec707b6
+
+---
+ gnu-efi-3.0/gnuefi/Makefile | 34 ++++++++++++----------------------
+ gnu-efi-3.0/inc/Makefile | 36 +++++++++++-------------------------
+ gnu-efi-3.0/lib/Makefile | 13 +++----------
+ 3 files changed, 26 insertions(+), 57 deletions(-)
+
+diff --git a/gnu-efi-3.0/gnuefi/Makefile b/gnu-efi-3.0/gnuefi/Makefile
+index 71e93f9..27f43b7 100644
+--- a/gnu-efi-3.0/gnuefi/Makefile
++++ b/gnu-efi-3.0/gnuefi/Makefile
+@@ -49,19 +49,6 @@ OBJS = $(FILES:%=%.o)
+
+ TARGETS = crt0-efi-$(ARCH).o libgnuefi.a
+
+-INSTALLTARGETS = $(TARGETS)
+-ifneq (,$(findstring FreeBSD,$(OS)))
+- ifeq ($(ARCH),x86_64)
+- INSTALLTARGETS += elf_$(ARCH)_fbsd_efi.lds
+- else
+- INSTALLTARGETS += elf_$(ARCH)_efi.lds
+- endif
+-else
+- INSTALLTARGETS += elf_$(ARCH)_efi.lds
+-endif
+-
+-LIBDIRINSTALL = $(INSTALLROOT)/$(LIBDIR)
+-
+ all: $(TARGETS)
+
+ libgnuefi.a: $(patsubst %,libgnuefi.a(%),$(OBJS))
+@@ -69,14 +56,17 @@ libgnuefi.a: $(patsubst %,libgnuefi.a(%),$(OBJS))
+ clean:
+ rm -f $(TARGETS) *~ *.o $(OBJS)
+
+-$(LIBDIRINSTALL):
+- mkdir -p $@
+-
+-.SECONDEXPANSION:
+-
+-$(LIBDIRINSTALL)/%: % | $$(dir $$@)
+- $(INSTALL) -m 644 $< $(dir $@)
+-
+-install: $(addprefix $(LIBDIRINSTALL)/,$(INSTALLTARGETS))
++install:
++ mkdir -p $(INSTALLROOT)/$(LIBDIR)
++ $(INSTALL) -m 644 $(TARGETS) $(INSTALLROOT)/$(LIBDIR)
++ifneq (,$(findstring FreeBSD,$(OS)))
++ ifeq ($(ARCH),x86_64)
++ $(INSTALL) -m 644 $(SRCDIR)/elf_$(ARCH)_fbsd_efi.lds $(INSTALLROOT)/$(LIBDIR)
++ else
++ $(INSTALL) -m 644 $(SRCDIR)/elf_$(ARCH)_efi.lds $(INSTALLROOT)/$(LIBDIR)
++ endif
++else
++ $(INSTALL) -m 644 $(SRCDIR)/elf_$(ARCH)_efi.lds $(INSTALLROOT)/$(LIBDIR)
++endif
+
+ include $(SRCDIR)/../Make.rules
+diff --git a/gnu-efi-3.0/inc/Makefile b/gnu-efi-3.0/inc/Makefile
+index 526af22..273d303 100644
+--- a/gnu-efi-3.0/inc/Makefile
++++ b/gnu-efi-3.0/inc/Makefile
+@@ -8,34 +8,20 @@ TOPDIR = $(SRCDIR)/..
+
+ CDIR=$(TOPDIR)/..
+
+-INCDIRINSTALL = $(INSTALLROOT)$(PREFIX)/include/efi
+-
+-SRCHEADERS = $(wildcard $(SRCDIR)/*.h) \
+- $(wildcard $(SRCDIR)/protocol/*.h) \
+- $(wildcard $(SRCDIR)/$(ARCH)/*.h)
+-ifeq ($(ARCH),ia64)
+- SRCHEADERS += $(wildcard $(SRCDIR)/protocol/$(ARCH)/*.h)
+-endif
+-
+-HEADERS = $(patsubst $(SRCDIR)/%,%,$(SRCHEADERS))
+-
+ all:
+
+ clean:
+
+- rm -f *~
+-
+-$(INCDIRINSTALL) \
+-$(INCDIRINSTALL)/protocol \
+-$(INCDIRINSTALL)/$(ARCH) \
+-$(INCDIRINSTALL)/protocol/$(ARCH):
+- mkdir -p $@
+-
+-.SECONDEXPANSION:
+-
+-$(INCDIRINSTALL)/%.h: %.h | $$(dir $$@)
+- $(INSTALL) -m 644 $< $(dir $@)
+-
+-install: $(addprefix $(INCDIRINSTALL)/,$(HEADERS))
++install:
++ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi
++ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/protocol
++ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/$(ARCH)
++ $(INSTALL) -m 644 $(SRCDIR)/*.h $(INSTALLROOT)$(PREFIX)/include/efi
++ $(INSTALL) -m 644 $(SRCDIR)/protocol/*.h $(INSTALLROOT)$(PREFIX)/include/efi/protocol
++ $(INSTALL) -m 644 $(SRCDIR)/$(ARCH)/*.h $(INSTALLROOT)$(PREFIX)/include/efi/$(ARCH)
++ifeq ($(ARCH),ia64)
++ mkdir -p $(INSTALLROOT)$(PREFIX)/include/efi/protocol/ia64
++ $(INSTALL) -m 644 $(SRCDIR)/protocol/ia64/*.h $(INSTALLROOT)$(PREFIX)/include/efi/protocol/ia64
++endif
+
+ include $(SRCDIR)/../Make.rules
+diff --git a/gnu-efi-3.0/lib/Makefile b/gnu-efi-3.0/lib/Makefile
+index d2635ad..e9f604e 100644
+--- a/gnu-efi-3.0/lib/Makefile
++++ b/gnu-efi-3.0/lib/Makefile
+@@ -61,11 +61,8 @@ OBJS = $(FILES:%=%.o)
+
+ SUBDIRS = ia32 x86_64 ia64 runtime
+
+-LIBDIRINSTALL = $(INSTALLROOT)/$(LIBDIR)
+-
+ all: libsubdirs libefi.a
+
+-.PHONY: libsubdirs
+ libsubdirs:
+ for sdir in $(SUBDIRS); do mkdir -p $$sdir; done
+
+@@ -74,13 +71,9 @@ libefi.a: $(patsubst %,libefi.a(%),$(OBJS))
+ clean:
+ rm -f libefi.a *~ $(OBJS) */*.o
+
+-$(LIBDIRINSTALL):
+- mkdir -p $@
+-
+-$(LIBDIRINSTALL)/libefi.a: libefi.a | $(LIBDIRINSTALL)
+- $(INSTALL) -m 644 $< $(dir $@)
+-
+-install: $(LIBDIRINSTALL)/libefi.a
++install: libefi.a
++ mkdir -p $(INSTALLROOT)/$(LIBDIR)
++ $(INSTALL) -m 644 libefi.a $(INSTALLROOT)/$(LIBDIR)
+
+ include $(SRCDIR)/../Make.rules
+
+--
+1.9.2
+