summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaan de Graaf2018-10-14 13:48:30 +0200
committerDaan de Graaf2018-10-14 13:48:30 +0200
commitb836b9d7995e6a98a797d9617d96386fc3ae4372 (patch)
tree761b745d8c7b63e2cf4655be2d26dff2854f08df
parent2ca0c2e595843c4c9ef4f153724cf0aadebc929e (diff)
downloadaur-b836b9d7995e6a98a797d9617d96386fc3ae4372.tar.gz
Update to version v2.8.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe7b4fffde6b..3e8fcfee640e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = gnuarmeclipse-qemu-bin
- pkgdesc = Fork, Cortex-M cores support, better integration with the GNU ARM QEMU Debugging plug-in
- pkgver = 2.7.0_201610290751
+ pkgdesc = The GNU MCU Eclipse QEMU is a fork of the public open-source QEMU project, customised for more support of Cortex-M cores, and a better integration with the GNU ARM QEMU Debugging plug-in.
+ pkgver = 2.8.0_3_20180523
pkgrel = 1
url = http://gnuarmeclipse.github.io/qemu/
- arch = i686
arch = x86_64
license = GPL
- provides = gnuarmeclipse-qemu
+ provides = qemu-system-gnuarmeclipse
options = !strip
- source_i686 = https://github.com/gnuarmeclipse/qemu/releases/download/gae-2.7.0-20161029/gnuarmeclipse-qemu-debian32-2.7.0-201610290751.tgz
- md5sums_i686 = b09312cbf97a6907cc618b5ae367232d
- source_x86_64 = https://github.com/gnuarmeclipse/qemu/releases/download/gae-2.7.0-20161029/gnuarmeclipse-qemu-debian64-2.7.0-201610290751.tgz
- md5sums_x86_64 = 33f834fc81cebfcee74ff7f1c7b6a3b7
+ source = https://github.com/gnu-mcu-eclipse/qemu/releases/download/v2.8.0-3-20180523/gnu-mcu-eclipse-qemu-2.8.0-3-20180523-0703-centos64.tgz
+ sha256sums = d4260a47b3322bce6d8d74feb2409b04c45f0b18a2958bb04ed2c802abf60793
pkgname = gnuarmeclipse-qemu-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8dddec5c8093..b02f5ce75770 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Michal Ulianko <michal dot ulianko at gmail dot com>
+# Maintainer: Daan de Graaf <daan de graaf 9 at gmail dot com>
pkgname=gnuarmeclipse-qemu-bin
-pkgver=2.7.0_201610290751
+pkgver=2.8.0_3_20180523
pkgrel=1
-pkgdesc="Fork, Cortex-M cores support, better integration with the GNU ARM QEMU Debugging plug-in"
-arch=('i686' 'x86_64')
+pkgdesc="The GNU MCU Eclipse QEMU is a fork of the public open-source QEMU project, customised for more support of Cortex-M cores, and a better integration with the GNU ARM QEMU Debugging plug-in."
+arch=('x86_64')
url="http://gnuarmeclipse.github.io/qemu/"
license=('GPL')
-provides=('gnuarmeclipse-qemu')
+provides=('qemu-system-gnuarmeclipse')
options=(!strip)
-source_i686=("https://github.com/gnuarmeclipse/qemu/releases/download/gae-2.7.0-20161029/gnuarmeclipse-qemu-debian32-2.7.0-201610290751.tgz")
-source_x86_64=("https://github.com/gnuarmeclipse/qemu/releases/download/gae-2.7.0-20161029/gnuarmeclipse-qemu-debian64-2.7.0-201610290751.tgz")
-md5sums_i686=('b09312cbf97a6907cc618b5ae367232d')
-md5sums_x86_64=('33f834fc81cebfcee74ff7f1c7b6a3b7')
+source=("https://github.com/gnu-mcu-eclipse/qemu/releases/download/v2.8.0-3-20180523/gnu-mcu-eclipse-qemu-2.8.0-3-20180523-0703-centos64.tgz")
+sha256sums=('d4260a47b3322bce6d8d74feb2409b04c45f0b18a2958bb04ed2c802abf60793')
package() {
- mkdir -p "$pkgdir/opt/gnuarmeclipse/qemu"
- cp -RPT -- "$srcdir/qemu/"*/ "$pkgdir/opt/gnuarmeclipse/qemu/"
+ install -d "${pkgdir}/opt/gnuarmeclipse/qemu"
+ install -d "${pkgdir}/usr/bin"
+ cp -r "${srcdir}/gnu-mcu-eclipse/qemu/2.8.0-3-20180523-0703/"* "${pkgdir}/opt/gnuarmeclipse/qemu/" -R
+ ln -s /opt/gnuarmeclipse/qemu/bin/qemu-system-gnuarmeclipse "${pkgdir}"/usr/bin/qemu-system-gnuarmeclipse
}